Bug 659959 - pkg-config information incorrect
Summary: pkg-config information incorrect
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libgcal
Version: 14
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Mario Santagiuliana
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 713741
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-04 12:55 UTC by Sjoerd Mullender
Modified: 2011-06-29 21:58 UTC (History)
1 user (show)

Fixed In Version: libgcal-0.9.6-5.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-29 21:56:54 UTC
Type: ---


Attachments (Terms of Use)

Description Sjoerd Mullender 2010-12-04 12:55:10 UTC
Description of problem:
The pkg-config information for package libgcal is incorrect.

Version-Release number of selected component (if applicable):
libgcal-devel-0.9.6-1.fc14.x86_64

How reproducible:
100%

Steps to Reproduce:
1.pkg-config --cflags libgcal
2.
3.
  
Actual results:
-I/usr/include/libgcal/libgcal -I/usr/include/libxml2

Expected results:
-I/usr/include/libgcal -I/usr/include/libxml2

Additional info:
Since the include file for libgcal is installed in the directory /usr/include/libgcal, that should be the directory that pkg-config will tell the compiler to use, not a non-existent subdirectory.

Comment 1 Chris Frey 2011-03-15 05:11:53 UTC
I ran into this one too.  It is easy to fix.  Just remove the patch from the rpm spec file: libgcal--pc_include_fix.diff.

The patch is no longer a fix, since this is mostly done by 0.9.6 already.

- Chris

Comment 2 Fedora Admin XMLRPC Client 2011-06-16 07:53:02 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 3 Fedora Update System 2011-06-16 15:31:36 UTC
libgcal-0.9.6-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/libgcal-0.9.6-5.fc15

Comment 4 Fedora Update System 2011-06-16 15:33:45 UTC
libgcal-0.9.6-5.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/libgcal-0.9.6-5.fc14

Comment 5 Fedora Update System 2011-06-21 17:07:09 UTC
Package libgcal-0.9.6-5.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libgcal-0.9.6-5.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/libgcal-0.9.6-5.fc15
then log in and leave karma (feedback).

Comment 6 Chris Frey 2011-06-27 21:24:55 UTC
Thanks!  The updated package solves my build problem.

Comment 7 Mario Santagiuliana 2011-06-27 22:55:06 UTC
Thanks Chris, please leave a positive karma like explained in comment 5.

Comment 8 Chris Frey 2011-06-27 23:20:31 UTC
Oy... I miss the days when actually fixing a bug and getting confirmation that it was fixed was enough to get it into a distro. :-)

These days you can't even report a bug without setting up some account with a password you forget every time you need to report a new bug.  And now we need two accounts, one on bugzilla and one on fedoraproject.  I can now forget two passwords per bug.  (Ubuntu is even worse... I can't even *get* an account on some of their services, due to some oddity in their server setups.)

Does no one see what this is doing to random contributors?  Does no one see what this is doing to Fedora?  This bug still exists in Fedora 14.

I know it's not your fault, but unless someone speaks up, this behaviour just keeps on going and going. :-)

Comment 9 Chris Frey 2011-06-28 00:39:28 UTC
I added a comment, but had trouble signing up.  Hopefully an anonymous comment is sufficient.

Comment 10 Mario Santagiuliana 2011-06-28 08:58:25 UTC
I think two registration are necessary because in this way a person can report a bug without subscribe the Fedora Controbutors License Agreement and bodhi system permits to leave a positive or negative karma in anonymous way.

If a contributor sign up the CLA and log in the bodhi the positive feedback is count and if the package receive 3 points it will push in stable. If the package receive no feedback I can push in stable after a week.
For more info:
http://fedoraproject.org/wiki/Bodhi

The new package for fedora 14 should resolve this bug, it works for me...

Comment 11 Fedora Update System 2011-06-29 21:56:44 UTC
libgcal-0.9.6-5.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2011-06-29 21:58:08 UTC
libgcal-0.9.6-5.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.