Bug 659993 - [abrt] deluge-1.3.0-1.fc14: optparse.py:1664:print_help:UnicodeDecodeError: 'ascii' codec can't decode byte 0xd0 in position 35: ordinal not in range(128)
Summary: [abrt] deluge-1.3.0-1.fc14: optparse.py:1664:print_help:UnicodeDecodeError: '...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: deluge
Version: 14
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Rahul Sundaram
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:95ecd27a
: 722757 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-04 18:48 UTC by Misha Shnurapet
Modified: 2011-11-28 17:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-28 17:16:43 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (1.33 KB, text/plain)
2010-12-04 18:48 UTC, Misha Shnurapet
no flags Details

Description Misha Shnurapet 2010-12-04 18:48:07 UTC
abrt version: 1.1.14
architecture: x86_64
cmdline: /usr/bin/python /usr/bin/deluge --help
component: deluge
executable: /usr/bin/deluge
kernel: 2.6.35.6-48.fc14.x86_64
package: deluge-1.3.0-1.fc14
reason: optparse.py:1664:print_help:UnicodeDecodeError: 'ascii' codec can't decode byte 0xd0 in position 35: ordinal not in range(128)
release: Fedora release 14 (Laughlin)
time: 1291488445
uid: 500

backtrace
-----
optparse.py:1664:print_help:UnicodeDecodeError: 'ascii' codec can't decode byte 0xd0 in position 35: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/bin/deluge", line 9, in <module>
    load_entry_point('deluge==1.3.0', 'console_scripts', 'deluge')()
  File "/usr/lib/python2.7/site-packages/deluge/main.py", line 79, in start_ui
    (options, args) = parser.parse_args()
  File "/usr/lib64/python2.7/optparse.py", line 1394, in parse_args
    stop = self._process_args(largs, rargs, values)
  File "/usr/lib64/python2.7/optparse.py", line 1434, in _process_args
    self._process_long_opt(rargs, values)
  File "/usr/lib64/python2.7/optparse.py", line 1509, in _process_long_opt
    option.process(opt, value, values, self)
  File "/usr/lib64/python2.7/optparse.py", line 788, in process
    self.action, self.dest, opt, value, values, parser)
  File "/usr/lib64/python2.7/optparse.py", line 810, in take_action
    parser.print_help()
  File "/usr/lib64/python2.7/optparse.py", line 1664, in print_help
    file.write(self.format_help().encode(encoding, "replace"))
UnicodeDecodeError: 'ascii' codec can't decode byte 0xd0 in position 35: ordinal not in range(128)

Local variables in innermost frame:
self: <optparse.OptionParser instance at 0x198ac20>
file: <open file '<stdout>', mode 'w' at 0x7f61c7d2b1e0>
encoding: 'UTF-8'

How to reproduce
-----
1. deluge --help
2.
3.

Comment 1 Misha Shnurapet 2010-12-04 18:48:11 UTC
Created attachment 464775 [details]
File: backtrace

Comment 2 Fedora Admin XMLRPC Client 2011-03-16 08:13:44 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 3 Calum 2011-11-28 17:11:54 UTC
*** Bug 722757 has been marked as a duplicate of this bug. ***

Comment 4 Calum 2011-11-28 17:16:43 UTC
Fixed in 1.3.3: http://dev.deluge-torrent.org/ticket/1637


Note You need to log in before you can comment on or make changes to this bug.