Bug 659999 - Keyboard applet translates the "belgian" keyboard layout as "belarussian"
Summary: Keyboard applet translates the "belgian" keyboard layout as "belarussian"
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora Localization
Classification: Fedora
Component: Dutch [nl]
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Bart Couvreur
QA Contact: Bart Couvreur
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-04 21:57 UTC by Pieter De Praetere
Modified: 2011-03-28 18:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-28 18:00:36 UTC


Attachments (Terms of Use)

Description Pieter De Praetere 2010-12-04 21:57:13 UTC
Description of problem:
The Keyboard switcher applet in the gnome panel erroneously translates the "Belgian" keyboard layout as "Wit" (from Wit-Russisch, the Dutch for Belarussian) This is probably due to an error in the way the applet determines which name to give to the keyboard layout, as the abbreviation for "Belgian" is "be" and for Belarussina is "bel". This could be an upstream issue, as I have seen this problem in Debian-based distros as well.


How reproducible:
Add another keyboard layout to the Dutch version of Fedora and the keyboard applet lists your "Belgian" keyboard layout as "Wit" (from Wit-Russisch)

Expected results:
The keyboard applet should display "Bel".

Comment 1 Geert Warrink 2011-03-28 17:10:39 UTC
I think this is a Gnome translation problem, as I can find no Fedora source with this translation. Please report this to the Gnome project.

Geert Warrink


Note You need to log in before you can comment on or make changes to this bug.