Bug 660034 - input-pad variant and option support
Summary: input-pad variant and option support
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: input-pad
Version: 15
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: fujiwara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-05 05:18 UTC by Jens Petersen
Modified: 2011-05-25 03:30 UTC (History)
2 users (show)

Fixed In Version: input-pad-1.0.1-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-25 02:57:30 UTC


Attachments (Terms of Use)

Description Jens Petersen 2010-12-05 05:18:39 UTC
Description of problem:
Haven't tried to debug but while testing noticed
that selecting China or Korea xkb layouts in input-pad
results in USA layout being selected.

Version-Release number of selected component (if applicable):
input-pad-1.0.0-1.fc14

How reproducible:
every time

Steps to Reproduce:
1. start input-pad
2. select China or Korea keyboard
3.
  
Actual results:
USA keyboard selected

Expected results:
China (or Korea) layout

Comment 1 fujiwara 2010-12-07 08:30:17 UTC
Currently input-pad supports layouts only.
I agree to support variants and options.

I guess the main issue is kr(kr104).

I also noticed another issue. GDK clients sometimes don't call XkbGetUpdatedMap() because MappingNotify event is not received.

Comment 3 Fedora Update System 2011-05-19 06:14:36 UTC
input-pad-1.0.1-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/input-pad-1.0.1-1.fc15

Comment 4 Fedora Update System 2011-05-19 06:14:43 UTC
input-pad-1.0.1-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/input-pad-1.0.1-2.fc14

Comment 5 Fedora Update System 2011-05-19 06:14:52 UTC
input-pad-1.0.1-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/input-pad-1.0.1-2.fc13

Comment 6 Fedora Update System 2011-05-19 21:59:22 UTC
Package input-pad-1.0.1-2.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing input-pad-1.0.1-2.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/input-pad-1.0.1-2.fc14
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2011-05-25 02:57:25 UTC
input-pad-1.0.1-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2011-05-25 03:24:55 UTC
input-pad-1.0.1-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2011-05-25 03:30:48 UTC
input-pad-1.0.1-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.