Bug 66004 - missing dependency in cups-drivers RPM
missing dependency in cups-drivers RPM
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: foomatic (Show other bugs)
7.3
All Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-04 15:30 EDT by Anand Buddhdev
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-18 13:26:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anand Buddhdev 2002-06-04 15:30:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
cups needs the filter /usr/lib/cups/filter/cupsomatic to be able to print to an
HP laserjet 5000 printer. This filter is part of foomatic, but foomatic is not
listed as a dependency of cups, and when I removed foomatic, cups stopped
printing. It took me over 2 hours to figure out the problem. So the cups RPM
should have foomatic as a dependency.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install cups, but NOT foomatic. Remove foomatic if already installed.
2. Configure an HP laserjet 5000 printer with cups
3. Attempt to print to this printer - it will fail
	

Actual Results:  Print jobs do not print. The error log for cups shows that the
filter process stopped with exit code 22. Not a very helpful description

Expected Results:  The file I submitted for printing should have printed.

Additional info:
Comment 1 Peter Schwenke 2002-08-05 21:51:16 EDT
I had a similar situation.  I'd installed cups previously on RH7.1 when I bought
my Epson Stylus Photo 1290.
(http://space.tin.it/computer/wvtberti/linux/stp_driver/gs_stp.htm back in
December) This was from an RPM linked from the  I chose the upgrade option for
RH7.3.  

Printing was completely broken until I eventually decided to reinstall cups from
my RedHat CDs and saw the cups-drivers RPMs.

Installing the drivers fixed the problem.
Comment 2 Tim Waugh 2002-10-11 07:34:48 EDT
cupsomatic is only needed for foomatic-created PPD files.  But yes, in general 
you often want to use them and a requirement certainly wouldn't hurt.
Comment 3 Tim Waugh 2002-10-17 06:18:06 EDT
Actually the problem is that the cups-drivers package doesn't require foomatic.
Comment 4 Tim Waugh 2002-10-21 13:04:59 EDT
cups-drivers package removed; redhat-config-printer has no need for it.

Note You need to log in before you can comment on or make changes to this bug.