Bug 660069 - Providing native systemd file for upcoming F15 Feature Systemd
Providing native systemd file for upcoming F15 Feature Systemd
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Guenther Deschner
Fedora Extras Quality Assurance
:
: 714445 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-05 07:01 EST by Michał Piotrowski
Modified: 2011-11-04 21:28 EDT (History)
8 users (show)

See Also:
Fixed In Version: samba-3.6.1-74.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-04 21:28:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
smb.service (194 bytes, text/plain)
2010-12-05 07:01 EST, Michał Piotrowski
no flags Details
nmb.service (194 bytes, text/plain)
2010-12-05 07:02 EST, Michał Piotrowski
no flags Details
windbind.service (206 bytes, text/plain)
2010-12-05 07:03 EST, Michał Piotrowski
no flags Details
correct smb.service file (249 bytes, text/plain)
2011-09-19 14:28 EDT, Jóhann B. Guðmundsson
no flags Details
correct nmb.service file (231 bytes, text/plain)
2011-09-19 14:29 EDT, Jóhann B. Guðmundsson
no flags Details
correct winbind.service file (305 bytes, text/plain)
2011-09-19 14:30 EDT, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Michał Piotrowski 2010-12-05 07:01:32 EST
Created attachment 464825 [details]
smb.service

The attached file is a native systemd file for upcoming F15 Feature [1]

Please read [2] on how to packaging and installing systemd Service files.

To learn more about Systemd daemon see [3].

To view old SysV with the new Systemd site by site see for your component see [4]

If you have any question dont hesitate to ask them on this bug report.

1.http://fedoraproject.org/wiki/Features/systemd

2.https://fedoraproject.org/wiki/Systemd_Packaging_Draft

3.http://0pointer.de/public/systemd-man/daemon.html

4.https://fedoraproject.org/wiki/User:Johannbg/QA/Systemd/compatability
Comment 1 Michał Piotrowski 2010-12-05 07:02:42 EST
Created attachment 464826 [details]
nmb.service
Comment 2 Michał Piotrowski 2010-12-05 07:03:06 EST
Created attachment 464827 [details]
windbind.service
Comment 3 Michał Piotrowski 2010-12-09 03:42:28 EST
These services should start after network.target
After=syslog.target network.target
Comment 4 Jóhann B. Guðmundsson 2011-06-29 12:44:14 EDT
What's the current status on this?

We need this in rawhide as soon as possible unless ofcourse you guys want to
block alpha.. 

https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
http://fedoraproject.org/wiki/Packaging:Tmpfiles.d
Comment 5 Michał Piotrowski 2011-06-29 14:22:21 EDT
I use modified version of smb.service (with After=syslog.target network.target) for over half year and it works fine here.
Comment 6 Guenther Deschner 2011-06-29 17:57:18 EDT
*** Bug 714445 has been marked as a duplicate of this bug. ***
Comment 7 Marcos Mello 2011-09-06 22:00:10 EDT
Ping.
The deadline for systemd native files inclusion is F16 beta! It will be sad don't have Samba package converted.
Comment 8 Jóhann B. Guðmundsson 2011-09-19 14:28:57 EDT
Created attachment 523882 [details]
correct smb.service file
Comment 9 Jóhann B. Guðmundsson 2011-09-19 14:29:38 EDT
Created attachment 523883 [details]
correct nmb.service file
Comment 10 Jóhann B. Guðmundsson 2011-09-19 14:30:23 EDT
Created attachment 523884 [details]
correct winbind.service file
Comment 11 Fedora Update System 2011-09-20 11:47:19 EDT
samba-3.6.0-72.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/samba-3.6.0-72.fc16
Comment 12 Fedora Update System 2011-09-20 15:03:34 EDT
Package samba-3.6.0-72.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing samba-3.6.0-72.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/samba-3.6.0-72.fc16
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2011-10-04 07:06:59 EDT
samba-3.6.0-73.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/samba-3.6.0-73.fc16
Comment 14 Fedora Update System 2011-10-26 11:58:53 EDT
samba-3.6.1-74.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/samba-3.6.1-74.fc16
Comment 15 Fedora Update System 2011-11-04 21:28:05 EDT
samba-3.6.1-74.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.