Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 660108 - tracker should not depend on QT
Summary: tracker should not depend on QT
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: tracker
Version: rawhide
Hardware: Unspecified
OS: Unspecified
urgent
low
Target Milestone: ---
Assignee: Deji Akingunola
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: depchain
TreeView+ depends on / blocked
 
Reported: 2010-12-05 15:21 UTC by Peter Robinson
Modified: 2011-01-04 19:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-04 19:04:44 UTC
Type: ---


Attachments (Terms of Use)

Description Peter Robinson 2010-12-05 15:21:54 UTC
Tracker should not depend on QT. The QT components should be split out into a tracker-qt sub package.

Comment 1 Jeff Raber 2010-12-08 02:33:17 UTC

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Christoph Wickert 2010-12-09 00:07:16 UTC
AFAICS nether tracker nor tracker search-tool depend on QT.

# rpm -q tracker --requires | grep qt
# rpm -q tracker-search-tool --requires | grep qt
# yum remove tracker
...
Dependencies Resolved

================================================================================
 Package                Arch    Version          Repository                Size
================================================================================
Removing:
 qt                     x86_64  1:4.7.1-3.fc14   @updates                  15 M
Removing for dependencies:
 PyQt4                  x86_64  4.7.4-2.fc14     @fedora                   14 M
 akonadi                x86_64  1.4.1-2.fc14     @updates                 2.2 M
 attica                 x86_64  0.1.4-1.fc14     @fedora                  448 k
 cagibi                 x86_64  0.1.1-2.fc14     @fedora                  172 k
 dbusmenu-qt            x86_64  0.6.3-1.fc14.1   @fedora                  207 k
 kdebase                x86_64  6:4.5.3-1.fc14   @updates                 8.6 M
 kdebase-libs           x86_64  6:4.5.3-1.fc14   @updates                 934 k
 kdebase-runtime        x86_64  4.5.3-3.fc14     @updates                  12 M
 kdebase-runtime-flags  noarch  4.5.3-3.fc14     @updates                 107 k
 kdebase-runtime-libs   x86_64  4.5.3-3.fc14     @updates                 3.5 M
 kdelibs                x86_64  6:4.5.3-3.fc14   @updates                  48 M
 kdepim                 x86_64  6:4.4.7-1.fc14   @updates                  19 M
 kdepim-libs            x86_64  6:4.4.7-1.fc14   @updates                  21 M
 kdepim-runtime         x86_64  4.4.7-1.fc14     @updates                 4.5 M
 kdepim-runtime-libs    x86_64  4.4.7-1.fc14     @updates                 330 k
 kdepimlibs             x86_64  4.5.3-2.fc14     @updates                 7.1 M
 kdepimlibs-akonadi     x86_64  4.5.3-2.fc14     @updates                 3.5 M
 kdeutils-minimal       x86_64  6:4.5.3-1.fc14   @updates                 4.1 M
 kdeutils-minimal-libs  x86_64  6:4.5.3-1.fc14   @updates                 201 k
 kwebkitpart            x86_64  0.9.6-1.fc14.1   @fedora                  706 k
 liveusb-creator        noarch  3.9.2-2.fc14     @fedora                  532 k
 phonon                 x86_64  4.4.2-1.fc14     @fedora                  529 k
 phonon-backend-xine    x86_64  4.4.2-1.fc14     @fedora                  442 k
 polkit-qt              x86_64  0.96.1-4.fc14    @fedora                  214 k
 qca2                   x86_64  2.0.2-2.fc12     @fedora                  1.4 M
 qimageblitz            x86_64  0.0.6-1.fc14     @fedora                  118 k
 qt-assistant-adp       x86_64  4.6.3-1.fc14     @fedora                  687 k
 qt-mysql               x86_64  1:4.7.1-3.fc14   @updates                  73 k
 qt-sqlite              x86_64  1:4.7.1-3.fc14   @updates                  49 k
 qt-webkit              x86_64  1:4.7.1-3.fc14   @updates                  21 M
 qt-x11                 x86_64  1:4.7.1-3.fc14   @updates                  34 M
 scribus                x86_64  1.3.8-1.fc14     @fedora                   41 M
 scribus-doc            noarch  1.3.8-1.fc14     @fedora                   12 M
 soprano                x86_64  2.5.2-1.fc14     @fedora                  2.1 M
 strigi-libs            x86_64  0.7.2-5.fc14     @fedora                  1.7 M
 vlc                    x86_64  1.1.5-1.fc14     @rpmfusion-free-updates  5.3 M
 vym                    x86_64  1.12.7-1.fc14    @fedora                  6.0 M

Transaction Summary
================================================================================
Remove       38 Package(s)

Comment 3 Deji Akingunola 2010-12-09 05:19:38 UTC
(In reply to comment #2)
> AFAICS nether tracker nor tracker search-tool depend on QT.
> 
tracker-0.9.30 in rawhide uses QT in its extractor library

Comment 4 Deji Akingunola 2010-12-09 05:23:14 UTC
(In reply to comment #0)
> Tracker should not depend on QT. The QT components should be split out into a
> tracker-qt sub package.

It can't be split out (in current tracker setup), the QT library is one of the many others used by the tracker extractor library for extracting music album arts.
Why do you think tracker cannot depend on QT?

Comment 5 Peter Robinson 2010-12-09 09:29:37 UTC
> Why do you think tracker cannot depend on QT?

Well I presumed by the fact that its a dependency it needs it. Given that is also depends on the whole GTK stack. It is generally considered to split out desktop specific requirements into the (see transmission* as an example). QT adds 75Mb to a standard install for devices that are resource constrainted like a table or an XO-1 (which has 1Gb of storage) using up 8% on a duplicate library isn't necessary.

Comment 6 Deji Akingunola 2011-01-04 19:04:44 UTC
Fixed in tracker-0.9.33-1.fc15 (now requires gdk-pixbuf instead of qt4 for album art extraction).

Thanks.


Note You need to log in before you can comment on or make changes to this bug.