Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 660165 - SELinux is preventing plymouthd from 'create' accesses on the file force-display-on-active-vt.
Summary: SELinux is preventing plymouthd from 'create' accesses on the file force-disp...
Keywords:
Status: CLOSED DUPLICATE of bug 659536
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:54b3aea7e68...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-05 23:20 UTC by Flóki Pálsson
Modified: 2010-12-06 09:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-06 09:42:04 UTC
Type: ---


Attachments (Terms of Use)

Description Flóki Pálsson 2010-12-05 23:20:30 UTC
SELinux is preventing plymouthd from 'create' accesses on the file force-display-on-active-vt.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that plymouthd should be allowed create access on the force-display-on-active-vt file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep plymouthd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:plymouthd_t:s0
Target Context                system_u:object_r:xdm_spool_t:s0
Target Objects                force-display-on-active-vt [ file ]
Source                        plymouthd
Source Path                   plymouthd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.9.10-6.fc15
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 2.6.36.1-11.fc15.x86_64 #1 SMP Fri
                              Dec 3 12:29:43 UTC 2010 x86_64 x86_64
Alert Count                   1
First Seen                    Sun 05 Dec 2010 11:11:30 PM GMT
Last Seen                     Sun 05 Dec 2010 11:11:30 PM GMT
Local ID                      17e4bc35-7807-48f0-84e0-95786db8b5a9

Raw Audit Messages
type=AVC msg=audit(1291590690.314:50): avc:  denied  { create } for  pid=903 comm="plymouthd" name="force-display-on-active-vt" scontext=system_u:system_r:plymouthd_t:s0 tcontext=system_u:object_r:xdm_spool_t:s0 tclass=file

plymouthd,plymouthd_t,xdm_spool_t,file,create

#============= plymouthd_t ==============
allow plymouthd_t xdm_spool_t:file create;

Comment 1 Miroslav Grepl 2010-12-06 09:42:04 UTC

*** This bug has been marked as a duplicate of bug 659536 ***


Note You need to log in before you can comment on or make changes to this bug.