Bug 660201 - Incorrect formatting for line wrapped cells with spreadsheet embedded in writer doc
Summary: Incorrect formatting for line wrapped cells with spreadsheet embedded in wri...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 14
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 660200 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-06 03:19 UTC by Martin Ebourne
Modified: 2010-12-28 21:00 UTC (History)
1 user (show)

Fixed In Version: openoffice.org-3.3.0-18.2.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-28 21:00:20 UTC
Type: ---


Attachments (Terms of Use)
Example of broken behaviour (13.83 KB, application/vnd.oasis.opendocument.text)
2010-12-06 03:21 UTC, Martin Ebourne
no flags Details
PDF output showing brokeness (14.12 KB, application/pdf)
2010-12-06 03:24 UTC, Martin Ebourne
no flags Details


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 32236 None None None Never
OpenOffice.org 115825 None None None Never

Description Martin Ebourne 2010-12-06 03:19:20 UTC
Description of problem:
Line wrapped cells in a spreadsheet embedded in a writer document are formatted incorrectly.

Version-Release number of selected component (if applicable):
openoffice.org-brand-3.3.0-17.2.fc14.x86_64
openoffice.org-calc-3.3.0-17.2.fc14.x86_64
openoffice.org-calc-core-3.3.0-17.2.fc14.x86_64
openoffice.org-core-3.3.0-17.2.fc14.x86_64
openoffice.org-draw-3.3.0-17.2.fc14.x86_64
openoffice.org-draw-core-3.3.0-17.2.fc14.x86_64
openoffice.org-graphicfilter-3.3.0-17.2.fc14.x86_64
openoffice.org-impress-3.3.0-17.2.fc14.x86_64
openoffice.org-impress-core-3.3.0-17.2.fc14.x86_64
openoffice.org-langpack-en-3.3.0-17.2.fc14.x86_64
openoffice.org-math-3.3.0-17.2.fc14.x86_64
openoffice.org-math-core-3.3.0-17.2.fc14.x86_64
openoffice.org-opensymbol-fonts-3.3.0-17.2.fc14.noarch
openoffice.org-pdfimport-3.3.0-17.2.fc14.x86_64
openoffice.org-presenter-screen-3.3.0-17.2.fc14.x86_64
openoffice.org-ure-3.3.0-17.2.fc14.x86_64
openoffice.org-writer2latex-1.0.2-3.fc14.x86_64
openoffice.org-writer-3.3.0-17.2.fc14.x86_64
openoffice.org-writer-core-3.3.0-17.2.fc14.x86_64
openoffice.org-xsltfilter-3.3.0-17.2.fc14.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Open new writer doc
2. Insert embedded calc OLE object
3. Enter some words in the first few cells
4. Format Cells -> Line wrap enabled
5. Click outside the sheet to edit the writer doc again

Actual results:
Formatting looks fine in sheet until you click back in writer and the OLE object returns to view mode, then the formatting is all broken, get repeating truncated text.

Expected results:
Should look exactly the same when not editing the sheet as it does when viewing it.

Additional info:
Affects at least screen display and PDF export.

Example broken document attached. Double-click on the text to see what it should look like. This was working fine on F13.

Comment 1 Martin Ebourne 2010-12-06 03:21:49 UTC
Created attachment 464918 [details]
Example of broken behaviour

Comment 2 Martin Ebourne 2010-12-06 03:24:56 UTC
Created attachment 464919 [details]
PDF output showing brokeness

See attached pdf output showing how it looks (and exports), obviously the text is not supposed to repeat and truncate.

Comment 3 Caolan McNamara 2010-12-09 13:18:52 UTC
Reproducible. Might be 64bit Only.

Comment 4 Caolan McNamara 2010-12-09 14:41:38 UTC
Rats, its a recent regression.

Comment 5 Caolan McNamara 2010-12-09 21:20:33 UTC
*** Bug 660200 has been marked as a duplicate of this bug. ***

Comment 6 Caolan McNamara 2010-12-12 14:27:30 UTC
Will be good in >= 3.3.0-17.3

Comment 7 Fedora Update System 2010-12-15 08:52:06 UTC
openoffice.org-3.3.0-18.1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/openoffice.org-3.3.0-18.1.fc14

Comment 8 Fedora Update System 2010-12-17 08:45:54 UTC
openoffice.org-3.3.0-18.1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/openoffice.org-3.3.0-18.1.fc14

Comment 9 Martin Ebourne 2010-12-20 01:00:43 UTC
Confirmed update fixes bug, thanks.

Comment 10 Fedora Update System 2010-12-21 12:10:00 UTC
openoffice.org-3.3.0-18.2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/openoffice.org-3.3.0-18.2.fc14

Comment 11 Fedora Update System 2010-12-28 20:59:43 UTC
openoffice.org-3.3.0-18.2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.