Bug 660316 - network install with manual/static ip settings does not apply/use DNS servers
Summary: network install with manual/static ip settings does not apply/use DNS servers
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Installation_Guide
Version: 5.5
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Jack Reed
QA Contact: ecs-bugs
URL:
Whiteboard:
Depends On:
Blocks: 795535 846182
TreeView+ depends on / blocked
 
Reported: 2010-12-06 14:02 UTC by Pasi Karkkainen
Modified: 2013-06-17 05:27 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 795535 (view as bug list)
Environment:
Last Closed: 2012-02-28 00:17:29 UTC


Attachments (Terms of Use)

Description Pasi Karkkainen 2010-12-06 14:02:24 UTC
Description of problem:
Installing RHEL 5.5 using network/pxe install (either on baremetal or as Xen domU) and using manual (static) ip settings asks for DNS server IP addresses, but it seems they're not used or set up. Installation using "ftp://server-dns-name/path" fails. "ftp://ip/path" works.

Version-Release number of selected component (if applicable):
RHEL 5.5

How reproducible:
Always.

Steps to Reproduce:
1. Boot from CD1 and do "askmethod" install using FTP with manual/static network settings. 
2. Or virt-install Xen domU using a bridge without dhcp server, so manual IP settings are required.
3. Submitted DNS server IP addresses are not being used, URL needs to use IP, DNS name won't work.
  
Actual results:
DNS names for the FTP URL do not work.

Expected results:
DNS names should work.

Additional info:
DNS server IP addresses are not copied to /etc/resolv.conf either. So after installing using ftp://IP/path and booting into the installed system /etc/resolv.conf does not contain DNS server IP addresses that were submitted in the network setup during installation.

Comment 1 Pasi Karkkainen 2010-12-06 14:04:13 UTC
Hmm, it also affects HTTP installs, so not ftp-only.

Comment 2 Radek Vykydal 2010-12-08 13:24:27 UTC
Your reproducer works for me (using http). Are you sure you provided the nameserver address correctly? Can you please attach /var/log/anaconda.log from installed (reproducer) system? Alternatively you can attach /tmp/anaconda.log gathered in install environment using scp from shell in tty2 (Ctrl-Alt-F2).

Comment 3 Pasi Karkkainen 2011-01-19 20:36:54 UTC
Ok, I'll have to investigate this a bit more and provide the logs you asked for.

Comment 4 Pasi Karkkainen 2011-03-28 08:10:44 UTC
I tested with 5.6 now and I figured it out.

If you give multiple DNS IP addresses, then anaconda fails to use them! If you just give single IP, it works!

I also verified when you give it multiple DNS IP addresses (and anaconda fails to use them) and you go to Ctrl-Alt-F2 there's no /etc/resolv.conf generated.

Do you still need the logs? This issue is 100% reproducible for me.

Comment 5 Radek Vykydal 2011-03-28 12:14:57 UTC
Ah, thanks for update, I didn't realized that the problem is using multiple dns addresses. I am afraid that we have never supported this in loader UI.

Comment 6 Pasi Karkkainen 2011-03-28 12:22:53 UTC
Yeah it's fine when you know that's the case.. but anaconda clearly should display an error message instead of failing silently!

Comment 7 David Cantrell 2011-07-27 17:51:44 UTC
Installation guide should be updated to reflect comment #4.

Comment 8 Michael Hideo 2011-07-27 20:51:10 UTC
(In reply to comment #7)
> Installation guide should be updated to reflect comment #4.

Rudi, can you please address comment #4 as per David's guidance? - Mike

Comment 9 Jack Reed 2011-09-19 05:54:11 UTC
Thanks, Pasi. For build 3.1-17 of the guide, I've expanded the 'Hostname of IP Address/Subnet' list item to state that only one IP address should be provided.

Comment 12 Jack Reed 2011-09-30 03:01:07 UTC
Good idea, Andrew. I've fixed that up.

Comment 14 Giulio Fidente 2012-02-08 10:09:45 UTC
This(In reply to comment #4)
> I tested with 5.6 now and I figured it out.
> 
> If you give multiple DNS IP addresses, then anaconda fails to use them! If you
> just give single IP, it works!
> 
> I also verified when you give it multiple DNS IP addresses (and anaconda fails
> to use them) and you go to Ctrl-Alt-F2 there's no /etc/resolv.conf generated.

We are having the same problem (/etc/resolv.conf has not been populated, after installation completes) even if we specify a single IP address as DNS server.

Can you reproduce and/or confirm it?


Note You need to log in before you can comment on or make changes to this bug.