Bug 660363 - No default route installed with initscripts-9.23-1.fc15
Summary: No default route installed with initscripts-9.23-1.fc15
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: rawhide
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-06 16:45 UTC by Jiri Popelka
Modified: 2014-03-17 03:25 UTC (History)
5 users (show)

Fixed In Version: initscripts-9.23-2.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-07 15:19:08 UTC
Type: ---


Attachments (Terms of Use)
patch (794 bytes, patch)
2010-12-06 20:03 UTC, Bill Nottingham
no flags Details | Diff

Description Jiri Popelka 2010-12-06 16:45:14 UTC
Version-Release number of selected component (if applicable):
initscripts-9.23-1.fc15

Steps to Reproduce:
1. ifcfg-eth0 contains:
DEVICE="eth0"
NM_CONTROLLED="no"
ONBOOT=yes
TYPE=Ethernet
BOOTPROTO=none
HWADDR=52:54:00:E9:54:CD
IPADDR=192.168.0.151
PREFIX=24
GATEWAY=192.168.0.1
DNS1=192.168.0.1
IPV6INIT=yes
IPV6ADDR=3ffe:501:ffff:0::151/64

2. NM is not installed
3. ip route show
  
Actual results:
192.168.0.0/24 dev eth0  proto kernel  scope link  src 192.168.0.151 
169.254.0.0/16 dev eth0  scope link  metric 1002 

Expected results:
192.168.0.0/24 dev eth0  proto kernel  scope link  src 192.168.0.151 
169.254.0.0/16 dev eth0  scope link  metric 1002 
default via 192.168.0.1 dev eth0 

Additional info:
Downgrading to initscripts-9.22-2.fc15 fixes the problem.

Comment 1 Bill Nottingham 2010-12-06 16:58:08 UTC
Almost certainly a regression caused by the patch for bug #633984... investigating.

Comment 2 Bill Nottingham 2010-12-06 20:03:55 UTC
Created attachment 465052 [details]
patch

This should fix it.

Comment 3 Jiri Popelka 2010-12-07 10:16:48 UTC
(In reply to comment #2)
> Created attachment 465052 [details]
> patch
> 
> This should fix it.

VERIFIED.


Note You need to log in before you can comment on or make changes to this bug.