Bug 660401 - SELinux is preventing /bin/dbus-daemon "read" access on localtime.
Summary: SELinux is preventing /bin/dbus-daemon "read" access on localtime.
Keywords:
Status: CLOSED DUPLICATE of bug 666557
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 14
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:3833b13679e...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-06 18:11 UTC by mail.pedro.nunes
Modified: 2011-01-05 08:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-05 08:31:33 UTC


Attachments (Terms of Use)

Description mail.pedro.nunes 2010-12-06 18:11:50 UTC
Summary:

SELinux is preventing /bin/dbus-daemon "read" access on localtime.

Detailed Description:

SELinux denied access requested by dbus-daemon. It is not expected that this
access is required by dbus-daemon and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023
Target Context                system_u:object_r:etc_runtime_t:s0
Target Objects                localtime [ file ]
Source                        dbus-daemon
Source Path                   /bin/dbus-daemon
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           dbus-1.4.0-1.fc14
Target RPM Packages           
Policy RPM                    selinux-policy-3.9.7-7.fc14
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.35.6-48.fc14.i686.PAE #1 SMP Fri
                              Oct 22 15:27:53 UTC 2010 i686 i686
Alert Count                   1
First Seen                    Tue 30 Nov 2010 10:51:27 AM WET
Last Seen                     Tue 30 Nov 2010 10:51:27 AM WET
Local ID                      c8928ada-93f1-4d75-a2c4-744397cdfc53
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1291114287.859:24253): avc:  denied  { read } for  pid=1649 comm="dbus-daemon" name="localtime" dev=dm-0 ino=2622560 scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:etc_runtime_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1291114287.859:24253): arch=40000003 syscall=5 success=no exit=-13 a0=4ef931 a1=0 a2=1b6 a3=4edbba items=0 ppid=1 pid=1649 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="dbus-daemon" exe="/bin/dbus-daemon" subj=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,dbus-daemon,xdm_dbusd_t,etc_runtime_t,file,read
audit2allow suggests:

#============= xdm_dbusd_t ==============
allow xdm_dbusd_t etc_runtime_t:file read;

Comment 1 Miroslav Grepl 2010-12-06 18:21:47 UTC
"localtime" is mislabeled. Execute

restorecon -R -v /etc/localtime


I am trying to find out where the problem is.

Comment 2 Miroslav Grepl 2010-12-09 18:17:04 UTC
Could you try to execute

# grep -r localtime /etc/init.d/

Comment 3 Daniel Walsh 2010-12-10 19:42:22 UTC
It could also be a dbus service.

Comment 4 Miroslav Grepl 2011-01-05 08:31:33 UTC

*** This bug has been marked as a duplicate of bug 666557 ***


Note You need to log in before you can comment on or make changes to this bug.