This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 660402 - Sometimes cannot start a VM without restarting libvirtd first ('Unable to create cgroup')
Sometimes cannot start a VM without restarting libvirtd first ('Unable to cre...
Status: CLOSED DUPLICATE of bug 666130
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-06 13:15 EST by Adam Williamson
Modified: 2011-06-05 03:57 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-23 17:55:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2010-12-06 13:15:00 EST
Sometimes, on Rawhide, when I try to run a VM - that is, actually when I hit the Run button - it fails to run. An error dialog pops up, which says:

"Error starting domain: Unable to create cgroup for Fedora13: No such file or directory"

There's a Details drop-down. When dropped down, it says:

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 878, in run_domain
    vm.startup()
  File "/usr/share/virt-manager/virtManager/domain.py", line 1321, in startup
    self._backend.create()
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 333, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: Unable to create cgroup for Fedora13: No such file or directory

This doesn't *always* happen. I think it happens when the system's been running for a while before I try to run a VM, or possibly after a suspend/resume cycle.

When this happens, I can solve it by restarting libvirtd. I don't have to quit/resume virt-manager; I can restart libvirtd with virt-manager running, re-connect to localhost in virt-manager, and then successfully start the VM.
Comment 1 Matěj Cepl 2011-01-21 05:36:03 EST
Me too (restart of libvirtd service helps) and this has a duplicate in bug 666130.
Comment 2 Cole Robinson 2011-03-23 17:55:59 EDT
Duping to the libvirt bug

*** This bug has been marked as a duplicate of bug 666130 ***

Note You need to log in before you can comment on or make changes to this bug.