Bug 660407 - [abrt] gvfs-smb-1.6.6-1.fc14: gkr_operation_block_and_unref: Process /usr/libexec/gvfsd-smb was killed by signal 6 (SIGABRT)
Summary: [abrt] gvfs-smb-1.6.6-1.fc14: gkr_operation_block_and_unref: Process /usr/lib...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-keyring
Version: 14
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Tomáš Bžatek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:9864d62bbbc8238fc4e6226b578...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-06 18:43 UTC by Francis Souza
Modified: 2015-03-03 22:56 UTC (History)
10 users (show)

Fixed In Version: libgnome-keyring-2.32.0-2.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-23 22:48:50 UTC


Attachments (Terms of Use)
File: backtrace (12.21 KB, text/plain)
2010-12-06 18:43 UTC, Francis Souza
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 644407 None None None Never

Description Francis Souza 2010-12-06 18:43:36 UTC
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: /usr/libexec/gvfsd-smb --spawner :1.10 /org/gtk/gvfs/exec_spaw/9
component: gvfs
crash_function: gkr_operation_block_and_unref
executable: /usr/libexec/gvfsd-smb
kernel: 2.6.35.9-64.fc14.x86_64
package: gvfs-smb-1.6.6-1.fc14
rating: 4
reason: Process /usr/libexec/gvfsd-smb was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1291660721
uid: 500

How to reproduce
-----
1. Double-clicking windows network icon 
2.
3.

Comment 1 Francis Souza 2010-12-06 18:43:37 UTC
Created attachment 465035 [details]
File: backtrace

Comment 2 Norm Powroz 2010-12-09 23:13:39 UTC
Package: gvfs-smb-1.6.6-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.attempting to create a shared directory on the system for access from Windows machines on the same network
2.
3.


Comment
-----
Entered the share parameters, clicked Proceed , boom

Comment 3 Scott Harvey 2011-01-15 21:57:35 UTC
Package: gvfs-smb-1.6.6-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.  Navigated to "Places" on Desktop Selected a previously setup share.
2.  Clicked on Share  password dialog box gameup, selected rember for this session
3.  DBUS dialog box came up


Comment
-----
This seems to happen after I boot.  I will try to mount the windows share again then it starts to work.

Comment 4 Alan Nutley 2011-01-17 09:32:17 UTC
Package: gvfs-smb-1.6.6-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Attempted to open existing bookmark to network location [previously accesssed w/o problem]
2.
3.

Comment 5 Scott Harvey 2011-02-05 19:24:07 UTC
Package: gvfs-smb-1.6.6-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.  Navigated to Places
2.  Seletcted a samba folder on a remote RH server
3.   System crashed.  


Comment
-----
This does not always happens but generally happens after a system restart

Comment 6 Martin Jürgens 2011-03-02 13:49:28 UTC
Package: gvfs-smb-1.6.6-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. connect to samba share
2. choose to never forget password
3.


Comment
-----
no

Comment 7 Martin Jürgens 2011-03-03 10:36:11 UTC
this has worked fine for years, no solution in sight.. now switching distro..

Comment 8 John J. Egan 2011-03-06 15:01:51 UTC
Package: gvfs-smb-1.6.6-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.In Network, navigate Windows Network/{domain}/Windows machine
2.Login to Windows (7) machine, editing domain
3.Select "User$" folder, login, editing domain  {CRASH}


Comment
-----
Suspicion: I may not have SHARED on the Windows machine.

Comment 9 John J. Egan 2011-03-06 15:04:12 UTC
I also checked Remember Forever - only in step 3, however.

Comment 10 Tomáš Bžatek 2011-03-10 13:15:17 UTC
(In reply to comment #1)
> func=0x3464016680 "gkr_operation_block_and_unref", message=0x7ff8fc090850 "assertion failed: (op->pending != pending)"

Don't see this problem here (F15).

Can you check that gnome-keyring-daemon is running at the time of the crash (or before)?

Comment 11 Tomáš Bžatek 2011-03-10 13:45:43 UTC
Moreover, have you seen any selinux denials?

Comment 12 Tomáš Bžatek 2011-03-10 15:55:35 UTC
Reported upstream: https://bugzilla.gnome.org/show_bug.cgi?id=644407

One last question - is this reproducible always?

Comment 13 Martin Jürgens 2011-03-10 19:10:04 UTC
Hi Tomas, thanks for looking into this. The problem is always reproducible. No selinux denials, I have also deactivated selinux for testing purposes..

g-k-d is running at the time of the crash. Also happens with clean profile.

Comment 14 Martin Jürgens 2011-03-10 19:30:29 UTC
i have just tried the upstream patch. fixes the problem. great!

Comment 15 Fedora Update System 2011-03-11 13:23:36 UTC
libgnome-keyring-2.32.0-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/libgnome-keyring-2.32.0-2.fc14

Comment 16 Fedora Update System 2011-03-23 22:48:34 UTC
libgnome-keyring-2.32.0-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.