Bug 660433 - Unregister from Kingpin causes wierd error
Summary: Unregister from Kingpin causes wierd error
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.1
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Devan Goodwin
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: Entitlement-Beta
TreeView+ depends on / blocked
 
Reported: 2010-12-06 19:12 UTC by Bryan Kearney
Modified: 2011-01-05 17:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-05 17:11:52 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Bryan Kearney 2010-12-06 19:12:03 UTC
I just repeated it to be sure: I went to the web interface kingpin -> Consumers and removed my system, then I fired up the RHSM gui and it says 'Unregister System'.  I clicked the unregister button and got the error here:
http://file.rdu.redhat.com/~jbastian/entitlement/rhsm-unregister.png

I closed the RHSM gui tool, restarted it, and it still says Unregister System.

Comment 2 Devan Goodwin 2011-01-05 16:02:54 UTC
Cannot reproduce in standalone, was trying to do so by using curl to delete the consumer in candlepin, which should be sufficient to trigger this. The error pops up, but the GUI button switches straight to "Register System". On restart it remains "Register System".

Dug through the code and I can't see how this would happen, the cert deletion is in a finally block which should clean them out even when the auth fails. (which is expected in this scenario)

I attempted to test directly against kingpin but I'm told using the test accounts could pose problems for QE. Have strong suspicion the standalone test steps above should cover it anyhow.

So, possible this has since been fixed? Anyone able to reproduce today?

Comment 3 Bryan Kearney 2011-01-05 16:10:33 UTC
what error do you get?

Comment 4 Devan Goodwin 2011-01-05 17:05:20 UTC
I get the error in the screenshot, this is expected behavior I think. (the consumer has been deleted, his identity cert is no longer valid to authenticate with, but the client has no way to know this)

The part with unregister however should clean up those certs and after that, the client should think it's unregistered, even if the auth fails when trying to unregister. That part is what I assumed this bug was about, but I cannot reproduce.

Comment 5 Bryan Kearney 2011-01-05 17:11:52 UTC
ok... I am fine with that.


Note You need to log in before you can comment on or make changes to this bug.