Bug 660513 - subscription-manager-gui: missing dependencies
Summary: subscription-manager-gui: missing dependencies
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Justin Harris
QA Contact: J.C. Molet
URL:
Whiteboard:
Depends On:
Blocks: Entitlement-Beta
TreeView+ depends on / blocked
 
Reported: 2010-12-06 23:34 UTC by J.C. Molet
Modified: 2013-07-04 21:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-19 13:37:55 UTC
Target Upstream Version:


Attachments (Terms of Use)
font selection failure (21.79 KB, image/png)
2010-12-06 23:35 UTC, J.C. Molet
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:0611 normal SHIPPED_LIVE new package: subscription-manager 2011-05-18 17:56:21 UTC

Description J.C. Molet 2010-12-06 23:34:29 UTC
Description of problem:

I kickstarted a rhel6 box with the following group packages:

Installed Groups:
   Additional Development
   Base
   Desktop Debugging and Performance Tools
   E-mail server
   General Purpose Desktop
   Graphical Administration Tools
   Hardware monitoring utilities
   Legacy UNIX compatibility
   Legacy X Window System compatibility
   Networking Tools
   Performance Tools
   Perl Support
   X Window System

This is a normal base install with the addition of the "X Window System" group packages. After installing subscription-manager-gui and all of its required dependencies, I was unable to launch it at all due to a missing dbus-x11 dependency.  After installing this, it launched, but with warnings, and no fonts were able to be rendered.

How reproducible:
100%

Steps to Reproduce:
1. Get a rhel6 base system with "X Window System", and virt-what installed
2. install subscription-manager-gui
3. run subscription-manager-gui
  
Actual results:
subscription-manager-gui fails to launch: 

root@mgmt5 rhsm]# subscription-manager-gui 

(subscription-manager-gui:2767): libglade-WARNING **: Unexpected element <property> inside <widget>.
/usr/share/rhsm/gui/managergui.py:80: PangoWarning: failed to choose a font, expect ugly output. engine-type='PangoRenderFc', script='latin'
  gtk.glade.XML.__init__(self, filename)

(subscription-manager-gui:2767): libglade-WARNING **: unknown attribute `swapped' for <signal>.

(subscription-manager-gui:2767): libglade-WARNING **: unknown attribute `swapped' for <signal>.
/usr/share/rhsm/gui/managergui.py:80: PangoWarning: failed to choose a font, expect ugly output. engine-type='PangoRenderFc', script='common'
  gtk.glade.XML.__init__(self, filename)
Traceback (most recent call last):
  File "/usr/sbin/subscription-manager-gui", line 92, in <module>
    bus = dbus.SessionBus()
  File "/usr/lib/python2.6/site-packages/dbus/_dbus.py", line 219, in __new__
    mainloop=mainloop)
  File "/usr/lib/python2.6/site-packages/dbus/_dbus.py", line 108, in __new__
    bus = BusConnection.__new__(subclass, bus_type, mainloop=mainloop)
  File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 125, in __new__
    bus = cls._new_for_bus(address_or_type, mainloop=mainloop)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.Spawn.ExecFailed: /bin/dbus-launch terminated abnormally without any error message


================================

After the 'dbus-x11' package is installed to remedy this, it launches but no font is able to be selected (see below and attached):


[root@mgmt4 ~]# subscription-manager-gui 
Gtk-Message: Failed to load module "atk-bridge": libatk-bridge.so: cannot open shared object file: No such file or directory

(subscription-manager-gui:21374): libglade-WARNING **: Unexpected element <property> inside <widget>.
/usr/share/rhsm/gui/managergui.py:80: PangoWarning: failed to choose a font, expect ugly output. engine-type='PangoRenderFc', script='latin'
  gtk.glade.XML.__init__(self, filename)

(subscription-manager-gui:21374): libglade-WARNING **: unknown attribute `swapped' for <signal>.

(subscription-manager-gui:21374): libglade-WARNING **: unknown attribute `swapped' for <signal>.
/usr/share/rhsm/gui/managergui.py:80: PangoWarning: failed to choose a font, expect ugly output. engine-type='PangoRenderFc', script='common'
  gtk.glade.XML.__init__(self, filename)

(subscription-manager-gui:21374): libglade-WARNING **: unknown attribute `swapped' for <signal>.

(subscription-manager-gui:21374): PkGtkModule-DEBUG: InstallFontconfigResources method invoked


Expected results:

It launches without errors and fonts are fully rendered.

Additional info:

I was able to get around the fonts issue by running a: 'yum install xorg-x11-fonts*' but was unsure of the specific basic font needed.

Comment 1 J.C. Molet 2010-12-06 23:35:32 UTC
Created attachment 465107 [details]
font selection failure

Comment 2 Justin Harris 2010-12-10 21:43:31 UTC
I was not able to reproduce the font issue. It looks like these are provided by "Legacy X Window System compatibility":


[root@rhel6 ~]# yum groupinfo "Legacy X Window System compatibility"
Loaded plugins: product-id, refresh-packagekit, rhnplugin, subscription-manager
Updating Red Hat repositories.
INFO:repolib:repos updated: 0
Setting up Group Process

Group: Legacy X Window System compatibility
 Description: Compatibility programs for migration from or working with legacy X Window System environments.
 Default Packages:
   xorg-x11-fonts-100dpi
   xorg-x11-fonts-ISO8859-1-100dpi
   xorg-x11-fonts-Type1
   xorg-x11-fonts-misc
 Optional Packages:
   libXmu
   libXp
   openmotif
   openmotif22
   xorg-x11-fonts-75dpi
   xorg-x11-fonts-ISO8859-1-75dpi
   xorg-x11-fonts-ISO8859-14-100dpi
   xorg-x11-fonts-ISO8859-14-75dpi
   xorg-x11-fonts-ISO8859-15-75dpi
   xorg-x11-fonts-ISO8859-2-100dpi
   xorg-x11-fonts-ISO8859-2-75dpi
   xorg-x11-fonts-ISO8859-9-100dpi
   xorg-x11-fonts-ISO8859-9-75dpi
   xorg-x11-fonts-cyrillic
   xorg-x11-fonts-ethiopic
   xorg-x11-twm
   xorg-x11-xdm
   xterm

Additionally, a recent change was made in subscription-manager that will gracefully allow the application to open if the session bus cannot be found on the system, so it is not a strict dependency.

Can we check this again and see if it is still an issue?

Comment 3 J.C. Molet 2010-12-13 14:21:10 UTC
updated to latest rhsm:

subscription-manager-gnome-0.93.3-1.git.7.ee2f586.fc14.x86_64
subscription-manager-0.93.3-1.git.7.ee2f586.fc14.x86_64

The dbus issue looks fixed now.

I did the following to test the fonts:

yum remove xorg-x11-fonts*
yum groupremove "Legacy X Window System compatibility"
yum groupinstall "Legacy X Window System compatibility"

to bring myself back to a base install.  This works for most all fonts.


Fonts for the password entry box when you register a system are still broken (however they do work now when you enter a password for the proxy configuration).

Also the icon for system compliance seems to be missing.

Comment 4 J.C. Molet 2010-12-21 14:38:41 UTC
raising password box issue as separate bug, dependencies are working.

Comment 5 errata-xmlrpc 2011-05-19 13:37:55 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0611.html


Note You need to log in before you can comment on or make changes to this bug.