Bug 66055 - Anacoda comps.HeaderListFromFile NFS kickstart install fails, Updated distro
Anacoda comps.HeaderListFromFile NFS kickstart install fails, Updated distro
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-04 20:36 EDT by Christian Pearce
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-06 20:39:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Pearce 2002-06-04 20:36:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.0.3 (X11; Linux i686; U;) Gecko/20020205

Description of problem:
In an attempt to automate as much as the install as possiable and given the
number of updates,  I built a updated version of the linux distribution.  I
copied redhat 7.2 from cd in to a directory I have NFS mounted.  I periodically
grab the updates from redhat 7.2 and use a utility to merge over the new RPMS
and remove the old ones.  Some updateMirror.pl program I tweaked a little bit. 
Then I run the

/usr/lib/anaconda-runtime/genhdlist  --withnumbers /home/tar/distros/redhat72/

This should update the hdlist files.  It worked before about 6 weeks ago.  Now
with a ks.cfg I used in the past it complains about some files that I add in
addition to groups.  Note the following ks.cfg :

# Commented out ones aren't working.
#perl-DB_File
#perl-CPAN
arpwatch
VFlib2-devel
libodbc++-devel
libogg-devel
#Omni-foomatic
shapecfg
#python-popt
#Omni
apache-devel
libvorbis-devel
kernel-enterprise
unixODBC-devel
gsm-devel
mysql-server
openldap-servers
php-imap
#perl-CGI
php-pgsql
#perl-NDBM_File
mysql
xpdf
libao-devel
php-mysql
unzip
audiofile-devel
cdrecord-devel

The ones that were giving troubles I commented out.  When they weren't commented
out I got the following :
  
 tility to merge over the new RPMS and remove the old ones.  Some
updateMirror.pl program I tweaked a little bit.  Then I run the

/usr/lib/anaconda-runtime/genhdlist  --withnumbers /home/tar/distros/redhat72/

This should update the hdlist files.  It worked before about 6 weeks ago.  Now
with a ks.cfg I used in the past it complains about some files that I add in
addition to groups.  Note the following ks.cfg :

 cat anacdump.txt 
Traceback (innermost last):
  File "/usr/bin/anaconda", line 620, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/gui.py", line 350, in run
    self.icw.run (self.runres, configFileData)
  File "/usr/lib/anaconda/gui.py", line 777, in run
    self.setup_window (runres)
  File "/usr/lib/anaconda/gui.py", line 757, in setup_window
    self.setScreen ()
  File "/usr/lib/anaconda/gui.py", line 504, in setScreen
    (step, args) = self.dispatch.currentStep()
  File "/usr/lib/anaconda/dispatch.py", line 243, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 143, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 208, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 102, in readPackages
    id.instClass.setPackageSelection(id.hdList)
  File "/usr/lib/anaconda/kickstart.py", line 847, in setPackageSelection
    hdlist[n].select()
  File "/usr/lib/anaconda/comps.py", line 152, in __getitem__
    return self.packages[item]
KeyError: python-popt

Local variables in innermost frame:
self: <comps.HeaderListFromFile instance at 85bcf80>
item: python-popt


Individual package selection status:
4Suite: 0, Canna: 0, Canna-devel: 0, Canna-libs: 0, Distut...

Finally when I removed the files from my ks.cfg, the ones I commented out above.
 It runs, but then stops and complains about needing those files to satisfy
dependencies.  Hence the reason I have them in the ks script.  Then the install
works fine and the files are in place.

Sorry this is a big one.  I combed for a similiar problem in the bugs list. 
Couldn't find it.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Build an updated distro to be NFS mounted
2. kickstart via DHCP
3. Wait for crash...
	

Additional info:
Comment 1 Jeremy Katz 2002-06-06 14:55:28 EDT
If you use the script at http://people.redhat.com/~katzj/dumphdrlist.py, do you
see the python-popt package listed in the output?   Also, do you have the
python-popt package in your tree?  Note that we will warn about unsatisfied
dependencies even if we can't figure out a resolution for them, so I'm betting
that you don't actually have these new packages.
Comment 2 Christian Pearce 2002-06-06 20:39:02 EDT
[pearcec@krusty base]$ dumphdrlist.py hdlist|grep python-popt 
0:python-popt-0.8.8-7.x.2.i386 1

Plus a few others from the kickstart script

[pearcec@krusty base]$ dumphdrlist.py hdlist | grep Omni
0:Omni-0.5.0-4.i386 1
0:Omni-foomatic-0.5.0-4.i386 1
[pearcec@krusty base]$ dumphdrlist.py hdlist | grep perl-DB_File
1:perl-DB_File-1.75-26.72.3.i386 1
[pearcec@krusty base]$ 

Note:  When I get to the dependencies resolution stage it warns about those RPMs
and then I hit go ahead and install them and everything works.

Here is to show you where I am building the hdlist from :

[pearcec@krusty RPMS]$ pwd
/home/tar/distros/redhat72/RedHat/RPMS
[pearcec@krusty RPMS]$ ls -la Omni-*
-rw-rw-r--    1 root     root     11330381 Oct 31  2001 Omni-0.5.0-4.i386.rpm
-rw-rw-r--    1 root     root        97968 Oct 31  2001
Omni-foomatic-0.5.0-4.i386.rpm
[pearcec@krusty RPMS]$ 


Note certain if this helps, but I setup 7.3 today and am not expericening any
problems.
Comment 3 Christian Pearce 2002-07-15 12:54:42 EDT
I saw this got closed today.  I believe the problem stemps from the fact that my
update script only copies over updates for existing RPM's and not new ones. 
There were some RPM's updates that recently added new files. I doubt I will get
time to verify this, I just wanted to get it on record for anyone else doing this.
Comment 4 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated

Note You need to log in before you can comment on or make changes to this bug.