Bug 660564 - RPM naming convention error
Summary: RPM naming convention error
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: ladspa-caps-plugins
Version: 14
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-07 05:55 UTC by Zoltan Hoppar
Modified: 2010-12-07 20:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-07 19:12:47 UTC
Type: ---


Attachments (Terms of Use)

Description Zoltan Hoppar 2010-12-07 05:55:06 UTC
Description of problem:
RPM naming error, what causing an dependency error

Version-Release number of selected component (if applicable):
ladspa-calf-plugins-0.0.18.6-1.fc14.1 (fc14.1????)

How reproducible:
Always

Steps to Reproduce:
1. Call for installing jack server and calf...and other music producer software
2. A bunch of sw needs dssi and ladspa plugins, but this naming in dependency prevents further installs

  
Actual results:
Two software needs dssi and calf plugins, but both looks for different package, but contains the same module

Expected results:
Rename the package, and use only single rpm for each of for both if it's possible

Additional info:

Comment 1 Zoltan Hoppar 2010-12-07 05:59:03 UTC
It seems that there are two sets of package, an that causing dependency problems. This includes calf too.

Comment 2 Brendan Jones 2010-12-07 12:50:01 UTC
Hi Zoltan - thanks for the bug report.

Can you please describe how you are installing these packages? Are you using yum. If so could you please include the command and the output here?

Also, the version numbering you are seeing is described here: http://fedoraproject.org/wiki/Packaging/NamingGuidelines#Release_Tag under minor release bump - it may shed some light on what you are seeing.

ladspa-calf-plugins-0.0.18.6-1.fc14.1 is also sitting in the updates repository as is a number of other related audio packages. You may want to post he output of yum check-update




-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Zoltan Hoppar 2010-12-07 19:12:47 UTC
It seems that I have run into some kind of sync problem, because of after I had reseted yum, and changed mirrors the update went well, and I could run JAMin, and the others. Maybe I have to forget packagekit gui...eh... My friend and I trying to put together an Music Studio fedora based, but first he wants to know the apps features, and he tries out on my machine. 

Thanks for the extra info, didn't know that release tag... Btw. do you know that BEAST (http://beast.gtk.org/) is packaged for Fedora (32/64bit)?

Comment 4 Brendan Jones 2010-12-07 20:42:57 UTC
There is lots of useful information here: http://fedoraproject.org/wiki/Audio_Creation 

I did not notice BEAST in the wishlist but if I have time I will try and package for you and get it submitted.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 5 Brendan Jones 2010-12-07 20:59:35 UTC
There may be an issue packaging beast due the optional MAD library which provides MP3 support which does not meet Fedora's licensing policy. I will look into it and let you know



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.