Bug 660584 - NFS transfer is very slow when RHEL5.5 guest's nic type is RTL8139
NFS transfer is very slow when RHEL5.5 guest's nic type is RTL8139
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: jason wang
Virtualization Bugs
: Triaged
: 660582 660583 (view as bug list)
Depends On:
Blocks: Rhel5KvmTier3
  Show dependency treegraph
 
Reported: 2010-12-07 03:01 EST by Qingtang Zhou
Modified: 2011-07-31 09:23 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-31 09:23:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output on guest os (16.00 KB, text/plain)
2010-12-07 03:17 EST, Qingtang Zhou
no flags Details

  None (edit)
Description Qingtang Zhou 2010-12-07 03:01:45 EST
Description of problem:
When installing OS on guest which have a rtl8139 card via NFS, I found a lot of packets is retransmitted or timeout, and file transmission via NFS is very slow.
Then I changed nic type to e1000, file transfer speed is back to normal.

           public net.                private net with a private bridge.
NFSServer-------------- Host(RHEL5.6)--------------Guest(RHEL5.5)


Version-Release number of selected component:
# rpm -q kernel
kernel-2.6.18-233.el5
# rpm -q kvm
kvm-83-219.el5

How reproducible:
100%

Steps to Reproduce:
1. Start a VM with following command, and start a unattended_install:
qemu -name 'vm1' 
-monitor unix:'/tmp/monitor-humanmonitor1-20101204-045808-YVkj',server,nowait 
-serial unix:'/tmp/serial-20101204-045808-YVkj',server,nowait 
-drive file='RHEL-Server-5.5-64.qcow2',index=0,if=ide,media=disk,cache=none,format=qcow2 
-net nic,vlan=0,model=rtl8139,macaddr='9a:25:00:89:f2:49' 
-net tap,vlan=0,ifname='t0-045808-YVkj',script='qemu-ifup-vbr0',downscript='no' -m 4096 -smp 2,cores=1,threads=1,sockets=2 
-drive file='rhel5-64/ks.iso',media=cdrom,index=1 
-cpu qemu64,+sse2 -soundhw ac97 
-kernel '/usr/local/staf/test/RHEV/kvm-new/autotest/client/tests/kvm/vmlinuz' 
-initrd '/usr/local/staf/test/RHEV/kvm-new/autotest/client/tests/kvm/initrd.img' -vnc :0 -spice port=8000,disable-ticketing -qxl 1 -rtc-td-hack -M rhel5.5.0 
-usbdevice tablet 
-append 'ks=cdrom console=ttyS0,115200 console=tty0' -no-kvm-pit-reinjection

2. tcpdump on the tap device guest created.
3. installation is slow, and many retransmission.
  
Actual results:
file transmission speed is slow, packet retransmission.

Expected results:
nearly no packet retransmission, file transmission speed is normal.

Additional info:
dmesg on guest os is attached.
Comment 1 Qingtang Zhou 2010-12-07 03:15:06 EST
*** Bug 660582 has been marked as a duplicate of this bug. ***
Comment 2 Qingtang Zhou 2010-12-07 03:15:42 EST
*** Bug 660583 has been marked as a duplicate of this bug. ***
Comment 3 Qingtang Zhou 2010-12-07 03:17:01 EST
Created attachment 465185 [details]
dmesg output on guest os

Note You need to log in before you can comment on or make changes to this bug.