Bug 660657 - application/xhtml+xml type missing in defaults.list
application/xhtml+xml type missing in defaults.list
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: shared-mime-info (Show other bugs)
14
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-07 09:15 EST by Karel Klíč
Modified: 2013-03-03 18:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-07 12:08:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Karel Klíč 2010-12-07 09:15:53 EST
The defaults.list contains a line that says "text/html=mozilla-firefox.desktop".
That is why `xdg-open index.html` and `gvfs-open index.xhtml` run Firefox.
Nevertheless, `xdg-open index.xhtml` and `gvfs-open index.xhtml` run Konqueror (on my F-14 machine, in GNOME).

It's because gvfs-open cannot find "application/xhtml+xml" in the defaults.list file, so it checks all .desktop files that support application/xhtml+xml, and chooses the first one to open the .xhtml file. Konqueror happens to be the first. When it's uninstalled, some other program becomes the first.

This is not consistent. For example GNU Emacs users use xdg-open to show previews of HTML pages they create (Emacs is preconfigured this way), and it runs firefox for file.html and some random browser for file.xhtml.

Please consider adding the following line below the text/html line in defaults.list:
application/xhtml+xml=mozilla-firefox.desktop

Thanks in advance.

Version-Release number of selected component:
Updated F-14, rawhide (I only checked the package source)
Comment 1 Karel Klíč 2010-12-07 09:17:40 EST
A typo on the third line:

`gvfs-open index.xhtml`

is supposed to be

`gvfs-open index.html`
Comment 2 Bastien Nocera 2010-12-07 12:08:17 EST
Done for rawhide.

For F14, right click on the file, and select Firefox as the default for this filetype in the properties.
Comment 3 Karel Klíč 2010-12-07 12:17:11 EST
Thank you.

Note You need to log in before you can comment on or make changes to this bug.