Bug 6607 - Upgrade 6.0>6.1 fails on Linux only system
Upgrade 6.0>6.1 fails on Linux only system
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-01 13:28 EST by lucb
Modified: 2015-01-07 18:39 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-29 11:18:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lucb 1999-11-01 13:28:33 EST
Hi,

when doing an upgrade using the updated bootnet.img and
updates.img, I still get a message that says the installer
cannot find any existing Linux partitions.

The only OS on this system is a RedHat 6.0 Workstation
install.  The last installer created the following
partitions
/dev/sda1   /boot
/dev/sda5   /
/dev/sda6   /swap

Does this problem also occur with CD-ROM local upgrades?

Please advise.
Luc Bouchard
Comment 1 Jay Turner 1999-11-02 11:38:59 EST
Run fdisk on the sda drive and check out what type of partition the
extended partition is (will probably be either type "5" or type "f")
If it is indeed type "f" then change it to type "5" (it will not harm
anything) and try the upgrade again.  Reopen this bug if you are still
having problems.

------- Additional Comments From   11/02/99 18:23 -------
Please reopen bug.
The partition type on the extended partition is 85 (Linux extended).
This would make sense since it was created by the RH6.0 installer on a
virgin drive.
Comment 2 lucb 1999-11-03 11:01:59 EST
Please reopen bug.
The partition type on the extended partition is 85 (Linux extended).
This would make sense since it was created by the RH6.0 installer on a
virgin drive.
Comment 3 lucb 1999-11-08 11:54:59 EST
Are there plans for a RH6.2 release in the near future?  I may sit out
the 6.1 release and wait if the timing is right.  Although, the latest
release of Gnome does not seem to be very stable on 6.0.  Any comments
would be helpfull.
Comment 4 Jay Turner 1999-11-09 12:23:59 EST
Please send me output from "fdisk -l /dev/sda" as well as a copy of
your /etc/fstab file.  I will then try and replicate the problem you
are seeing in the lab.
Comment 5 lucb 1999-11-09 19:27:59 EST
Item 1:

[root@ptm /root]# fdisk -l /dev/sda

Disk /dev/sda: 255 heads, 63 sectors, 261 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/sda1   *         1         3     24066   83  Linux
/dev/sda2             4       261   2072385   85  Linux extended
/dev/sda5             4       252   2000061   83  Linux
/dev/sda6           253       261     72261   82  Linux swap

Item 2: /etc/fstab

/dev/sda5   /                   ext2    defaults        1 1
/dev/sda1   /boot               ext2    defaults        1 2
/dev/sda6   swap                swap    defaults        0 0
/dev/fd0    /mnt/floppy         ext2    noauto          0 0
/dev/cdrom  /mnt/cdrom          iso9660 noauto,ro       0 0
/dev/cdrom2 /mnt/cdrom2		iso9660 noauto,ro	0 0
none        /proc               proc    defaults        0 0
none        /dev/pts            devpts  gid=5,mode=620  0 0
ren:/home   /mnt/renhome	nfs	defaults	0 0
Comment 6 Jay Turner 1999-11-22 12:55:59 EST
My recommendation is that you change the partition type of /dev/sda2 from type
"85" to type "5"  I think the linux extended partition is throwing off the 6.1
installer and that is why the installer is not able to see the existing linux
installation.
Comment 7 lucb 1999-11-23 11:07:59 EST
A few questions:
1) So I change the type to "5" then upgrade then change the type back to 85?
2) What is the impact of going from a Linux Extended Partition (85) to a
Winbloze Extended Partition (5). My understanding is that I could blow away the
contents of the partition.  Is this correct.

Let me know, thanks.
Comment 8 Jay Turner 1999-11-29 11:18:59 EST
Yes, it could cause data loss, but there is a better solution.  We should be
putting out another updates image which will fix these problems you are seeing.
Hold out for the errata and then it will not be an issue.
Comment 9 lucb 1999-11-29 11:29:59 EST
Will do.  What is the timeframe on the errata release?
Comment 10 lucb 1999-12-08 08:59:59 EST
Don't worry about any further testing, I bought the media and re-installed from
scratch on my local CD-ROM.

Note You need to log in before you can comment on or make changes to this bug.