Bug 660798 - FTBFS blackbox-0.70.1-14
FTBFS blackbox-0.70.1-14
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: blackbox (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
http://sourceforge.net/tracker/?func=...
: Patch, Triaged
: 715743 (view as bug list)
Depends On:
Blocks: F15FTBFS
  Show dependency treegraph
 
Reported: 2010-12-07 12:59 EST by FTBFS
Modified: 2012-01-19 04:34 EST (History)
3 users (show)

See Also:
Fixed In Version: blackbox-0.70.1-17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-19 04:34:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (95.19 KB, text/plain)
2010-12-07 12:59 EST, FTBFS
no flags Details
build.log (24.73 KB, text/plain)
2010-12-07 12:59 EST, FTBFS
no flags Details
mock.log (863 bytes, text/plain)
2010-12-07 12:59 EST, FTBFS
no flags Details
root.log (186.37 KB, text/plain)
2010-12-07 12:59 EST, FTBFS
no flags Details
build.log (24.32 KB, text/plain)
2010-12-07 12:59 EST, FTBFS
no flags Details
mock.log (948 bytes, text/plain)
2010-12-07 12:59 EST, FTBFS
no flags Details
fix including Xutils.h (510 bytes, patch)
2011-03-25 21:16 EDT, Niels de Vos
no flags Details | Diff
Update the spec to apply blackbox-0.70.1_Xutil.patch as well (1.20 KB, patch)
2011-03-25 21:18 EDT, Niels de Vos
no flags Details | Diff

  None (edit)
Description FTBFS 2010-12-07 12:59:47 EST
blackbox-0.70.1-14.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-12-07 12:59:50 EST
Created attachment 465623 [details]
root.log


root.log for i386
Comment 2 FTBFS 2010-12-07 12:59:51 EST
Created attachment 465624 [details]
build.log


build.log for i386
Comment 3 FTBFS 2010-12-07 12:59:52 EST
Created attachment 465625 [details]
mock.log


mock.log for i386
Comment 4 FTBFS 2010-12-07 12:59:54 EST
Created attachment 465626 [details]
root.log


root.log for x86_64
Comment 5 FTBFS 2010-12-07 12:59:55 EST
Created attachment 465627 [details]
build.log


build.log for x86_64
Comment 6 FTBFS 2010-12-07 12:59:56 EST
Created attachment 465628 [details]
mock.log


mock.log for x86_64
Comment 7 Niels de Vos 2011-03-25 21:16:36 EDT
Created attachment 487698 [details]
fix including Xutils.h
Comment 8 Niels de Vos 2011-03-25 21:18:08 EDT
Created attachment 487699 [details]
Update the spec to apply blackbox-0.70.1_Xutil.patch as well
Comment 9 Niels de Vos 2011-03-25 21:20:15 EDT
With the additional patch and applying it in the spec-file, building succeeds again. Please check and apply when suitable. Thanks!


$ fedpkg scratch-build --srpm blackbox-0.70.1-16.fc16.src.rpm 
[====================================] 100% 00:00:05 492.47 KiB  90.10 KiB/sec
Building blackbox-0.70.1-16.fc16 for dist-rawhide
Created task: 2947037
Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=2947037
Watching tasks (this may be safely interrupted)...
2947037 build (dist-rawhide, blackbox-0.70.1-16.fc16.src.rpm): open (x86-05.phx2.fedoraproject.org)
  2947039 buildArch (blackbox-0.70.1-16.fc16.src.rpm, i686): free
  2947038 buildArch (blackbox-0.70.1-16.fc16.src.rpm, x86_64): open (x86-20.phx2.fedoraproject.org)
  2947039 buildArch (blackbox-0.70.1-16.fc16.src.rpm, i686): free -> open (x86-06.phx2.fedoraproject.org)
  2947038 buildArch (blackbox-0.70.1-16.fc16.src.rpm, x86_64): open (x86-20.phx2.fedoraproject.org) -> closed
  0 free  2 open  1 done  0 failed
  2947039 buildArch (blackbox-0.70.1-16.fc16.src.rpm, i686): open (x86-06.phx2.fedoraproject.org) -> closed
  0 free  1 open  2 done  0 failed
2947037 build (dist-rawhide, blackbox-0.70.1-16.fc16.src.rpm): open (x86-05.phx2.fedoraproject.org) -> closed
  0 free  0 open  3 done  0 failed

2947037 build (dist-rawhide, blackbox-0.70.1-16.fc16.src.rpm) completed successfully
Comment 10 Petr Pisar 2012-01-19 04:03:18 EST
*** Bug 715743 has been marked as a duplicate of this bug. ***
Comment 11 Petr Pisar 2012-01-19 04:13:20 EST
This bug is tracked by upstream at <http://sourceforge.net/tracker/?func=detail&aid=3239068&group_id=40696&atid=428680>.

Note You need to log in before you can comment on or make changes to this bug.