Bug 660839 - FTBFS knutclient-1.0.3-2.fc14
FTBFS knutclient-1.0.3-2.fc14
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: knutclient (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Eli Wapniarski
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: F15FTBFS
  Show dependency treegraph
 
Reported: 2010-12-07 13:07 EST by FTBFS
Modified: 2011-06-16 15:05 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-09 16:04:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (896.63 KB, text/plain)
2010-12-07 13:07 EST, FTBFS
no flags Details
build.log (125.00 KB, text/plain)
2010-12-07 13:07 EST, FTBFS
no flags Details
mock.log (957 bytes, text/plain)
2010-12-07 13:07 EST, FTBFS
no flags Details
root.log (1.27 MB, text/plain)
2010-12-07 13:07 EST, FTBFS
no flags Details
build.log (124.82 KB, text/plain)
2010-12-07 13:07 EST, FTBFS
no flags Details
mock.log (965 bytes, text/plain)
2010-12-07 13:07 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-12-07 13:07:25 EST
knutclient-1.0.3-2.fc14.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-12-07 13:07:30 EST
Created attachment 465854 [details]
root.log


root.log for i386
Comment 2 FTBFS 2010-12-07 13:07:31 EST
Created attachment 465855 [details]
build.log


build.log for i386
Comment 3 FTBFS 2010-12-07 13:07:32 EST
Created attachment 465856 [details]
mock.log


mock.log for i386
Comment 4 FTBFS 2010-12-07 13:07:35 EST
Created attachment 465857 [details]
root.log


root.log for x86_64
Comment 5 FTBFS 2010-12-07 13:07:36 EST
Created attachment 465858 [details]
build.log


build.log for x86_64
Comment 6 FTBFS 2010-12-07 13:07:38 EST
Created attachment 465859 [details]
mock.log


mock.log for x86_64
Comment 7 Laurent Rineau 2010-12-08 02:45:35 EST
The relevant error is that one, in build.log:

/builddir/build/BUILD/knutclient-1.0.3/src/knutvardata.cpp:56:1: error: control reaches end of non-void function
Comment 8 Eli Wapniarski 2010-12-08 06:47:54 EST
Which means that there is a bug in the software and should be reported upstream?
Comment 9 Kevin Kofler 2010-12-08 06:57:43 EST
Yes.

But patching the code to return something (usually 0) is a one-line fix.
Comment 10 Eli Wapniarski 2010-12-09 00:38:57 EST
That's something that I need to leave to a programmer :)

I've reported the problem upstream via email because there are no indicated bug reporting facilities on the app's home page.

I will let you know what response I get.

In the meantime if there is some kind soul that would be willing to provide a patch, I would be greatly appreciative.
Comment 11 Eli Wapniarski 2010-12-09 16:04:50 EST
I just received a new version from the developer and when I built the package I got:

2655813 build (dist-rawhide, /knutclient:d952ee6d674b3594ba625078bd0e0a088ff283f5) completed successfully

Thanks Laurent and Kevin for your help

Closing this one :)

Note You need to log in before you can comment on or make changes to this bug.