Bug 660867 - FTBFS gnome-desktop-sharp-2.26.0-9.fc15
FTBFS gnome-desktop-sharp-2.26.0-9.fc15
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-desktop-sharp (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Christian Krause
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: F15FTBFS
  Show dependency treegraph
 
Reported: 2010-12-07 13:12 EST by FTBFS
Modified: 2011-06-16 15:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-20 16:03:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (1014.23 KB, text/plain)
2010-12-07 13:12 EST, FTBFS
no flags Details
build.log (38.71 KB, text/plain)
2010-12-07 13:12 EST, FTBFS
no flags Details
mock.log (919 bytes, text/plain)
2010-12-07 13:12 EST, FTBFS
no flags Details
root.log (1.45 MB, text/plain)
2010-12-07 13:12 EST, FTBFS
no flags Details
build.log (39.20 KB, text/plain)
2010-12-07 13:12 EST, FTBFS
no flags Details
mock.log (927 bytes, text/plain)
2010-12-07 13:12 EST, FTBFS
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 664279 None None None Never
Novell 660440 None None None Never

  None (edit)
Description FTBFS 2010-12-07 13:12:37 EST
gnome-desktop-sharp-2.26.0-9.fc15.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-12-07 13:12:41 EST
Created attachment 466018 [details]
root.log


root.log for i386
Comment 2 FTBFS 2010-12-07 13:12:42 EST
Created attachment 466019 [details]
build.log


build.log for i386
Comment 3 FTBFS 2010-12-07 13:12:43 EST
Created attachment 466020 [details]
mock.log


mock.log for i386
Comment 4 FTBFS 2010-12-07 13:12:46 EST
Created attachment 466021 [details]
root.log


root.log for x86_64
Comment 5 FTBFS 2010-12-07 13:12:48 EST
Created attachment 466022 [details]
build.log


build.log for x86_64
Comment 6 FTBFS 2010-12-07 13:12:49 EST
Created attachment 466023 [details]
mock.log


mock.log for x86_64
Comment 7 Christian Krause 2010-12-19 06:22:23 EST
gnome-desktop-sharp uses it's own definition for the gtkhtml3 API (gnome-desktop-sharp-2.26.0/gtkhtml/gtkhtml-api.raw) which is now out of sync with gtkhtml3-3.91.3 due to the API changes for the gtk3 transistion. I have reported the bug upstream:
https://bugzilla.novell.com/show_bug.cgi?id=660440
Comment 8 Christian Krause 2010-12-19 11:23:28 EST
Just for reference: Upstream claims that's an issue with gtkhtml3 breaking its API: https://bugzilla.redhat.com/show_bug.cgi?id=664279 .
Comment 9 Matthew Barnes 2010-12-19 15:27:29 EST
Absolutely nothing but Evolution should be linking to gtkhtml3 at this point, not even language bindings.  The package will likely be orphaned upstream within the next year.  I'd recommend building with --disable-gtkhtml.
Comment 10 Christian Krause 2010-12-20 16:03:19 EST
Due to the lack of the --disable-gtkhtml switch I have removed gtkhtml3-devel from the package's dependency list to compile it without gtkhtml3 support.

Note You need to log in before you can comment on or make changes to this bug.