Bug 660884 - FTBFS fltk-1.1.10-4.fc15: ImplicitDSOLinking
FTBFS fltk-1.1.10-4.fc15: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fltk (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: F15FTBFS
  Show dependency treegraph
 
Reported: 2010-12-07 13:15 EST by FTBFS
Modified: 2011-06-16 15:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-07 14:32:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (331.22 KB, text/plain)
2010-12-07 13:15 EST, FTBFS
no flags Details
build.log (116.31 KB, text/plain)
2010-12-07 13:15 EST, FTBFS
no flags Details
mock.log (858 bytes, text/plain)
2010-12-07 13:15 EST, FTBFS
no flags Details
root.log (493.48 KB, text/plain)
2010-12-07 13:15 EST, FTBFS
no flags Details
build.log (105.78 KB, text/plain)
2010-12-07 13:15 EST, FTBFS
no flags Details
mock.log (944 bytes, text/plain)
2010-12-07 13:15 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-12-07 13:15:20 EST
fltk-1.1.10-4.fc15.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-12-07 13:15:23 EST
Created attachment 466097 [details]
root.log


root.log for i386
Comment 2 FTBFS 2010-12-07 13:15:25 EST
Created attachment 466098 [details]
build.log


build.log for i386
Comment 3 FTBFS 2010-12-07 13:15:26 EST
Created attachment 466099 [details]
mock.log


mock.log for i386
Comment 4 FTBFS 2010-12-07 13:15:28 EST
Created attachment 466100 [details]
root.log


root.log for x86_64
Comment 5 FTBFS 2010-12-07 13:15:29 EST
Created attachment 466101 [details]
build.log


build.log for x86_64
Comment 6 FTBFS 2010-12-07 13:15:30 EST
Created attachment 466102 [details]
mock.log


mock.log for x86_64
Comment 7 Rex Dieter 2010-12-07 14:32:02 EST
Interesting that DSO Linking wrt static linking has changed wrt < f15

Anyway, fixed now,

Changelog:
* Tue Dec 07 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.1.10-5
- FTBFS fltk-1.1.10-4.fc15: ImplicitDSOLinking (#660884)

Note You need to log in before you can comment on or make changes to this bug.