Bug 660901 - FTBFS maven-ant-tasks-2.1.1-4.fc15
FTBFS maven-ant-tasks-2.1.1-4.fc15
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: maven-ant-tasks (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: F15FTBFS
  Show dependency treegraph
 
Reported: 2010-12-07 13:18 EST by FTBFS
Modified: 2011-06-16 15:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-07 16:05:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (630.02 KB, text/plain)
2010-12-07 13:18 EST, FTBFS
no flags Details
build.log (134.44 KB, text/plain)
2010-12-07 13:18 EST, FTBFS
no flags Details
mock.log (899 bytes, text/plain)
2010-12-07 13:18 EST, FTBFS
no flags Details
root.log (701.19 KB, text/plain)
2010-12-07 13:18 EST, FTBFS
no flags Details
build.log (134.47 KB, text/plain)
2010-12-07 13:18 EST, FTBFS
no flags Details
mock.log (908 bytes, text/plain)
2010-12-07 13:18 EST, FTBFS
no flags Details
ant-run-plugin-with-ant-1.6/build.log (256.83 KB, text/plain)
2010-12-07 15:05 EST, Orion Poplawski
no flags Details
ant-tasks-in-ant-run-plugin/build.log (87.99 KB, text/plain)
2010-12-07 15:06 EST, Orion Poplawski
no flags Details

  None (edit)
Description FTBFS 2010-12-07 13:18:14 EST
maven-ant-tasks-2.1.1-4.fc15.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-12-07 13:18:17 EST
Created attachment 466185 [details]
root.log


root.log for i386
Comment 2 FTBFS 2010-12-07 13:18:18 EST
Created attachment 466186 [details]
build.log


build.log for i386
Comment 3 FTBFS 2010-12-07 13:18:20 EST
Created attachment 466187 [details]
mock.log


mock.log for i386
Comment 4 FTBFS 2010-12-07 13:18:22 EST
Created attachment 466188 [details]
root.log


root.log for x86_64
Comment 5 FTBFS 2010-12-07 13:18:23 EST
Created attachment 466189 [details]
build.log


build.log for x86_64
Comment 6 FTBFS 2010-12-07 13:18:24 EST
Created attachment 466190 [details]
mock.log


mock.log for x86_64
Comment 7 Orion Poplawski 2010-12-07 15:05:46 EST
Created attachment 467293 [details]
ant-run-plugin-with-ant-1.6/build.log
Comment 8 Orion Poplawski 2010-12-07 15:06:46 EST
Created attachment 467294 [details]
ant-tasks-in-ant-run-plugin/build.log
Comment 9 Orion Poplawski 2010-12-07 15:12:15 EST
Java Sig -  Need help here.  It's the integration tests that are failing:

[INFO] [invoker:install {execution: integration-test}]
[INFO] Installing /builddir/build/BUILD/maven-ant-tasks-2.1.1/pom.xml to /builddir/build/BUILD/maven-ant-tasks-2.1.1/target/local-repo/org/apache/maven/maven-ant-tasks/2.1.1/maven-ant-tasks-2.1.1.pom
[INFO] Installing /builddir/build/BUILD/maven-ant-tasks-2.1.1/target/maven-ant-tasks-2.1.1.jar to /builddir/build/BUILD/maven-ant-tasks-2.1.1/target/local-repo/org/apache/maven/maven-ant-tasks/2.1.1/maven-ant-tasks-2.1.1.jar
[INFO] [invoker:run {execution: integration-test}]
[WARNING] File encoding has not been set, using platform encoding ANSI_X3.4-1968, i.e. build is platform dependent!
[INFO] Building: ant-run-plugin-with-ant-1.6/pom.xml
[INFO] ..FAILED (1.9 s)
[INFO]   The build exited with code 1. See /builddir/build/BUILD/maven-ant-tasks-2.1.1/target/it/ant-run-plugin-with-ant-1.6/build.log for details.
[INFO] Building: ant-tasks-in-ant-run-plugin/pom.xml
[INFO] ..FAILED (1.6 s)
[INFO]   The build exited with code 1. See /builddir/build/BUILD/maven-ant-tasks-2.1.1/target/it/ant-tasks-in-ant-run-plugin/build.log for details.

I've attached those build.logs to the bug.  They are failing with missing deps - no idea why.  Perhaps because it is invoking plain maven rather than mvn-jpp and so doesn't find the local poms?

Missing:
ant-run-plugin-with-ant-1.6-build.log:1) ant:ant:jar:1.6
ant-run-plugin-with-ant-1.6-build.log:2) ant:ant-launcher:jar:1.6

ant-tasks-in-ant-run-plugin-build.log:1) ant:ant-launcher:jar:1.8.0
Comment 10 Alexander Kurtakov 2010-12-07 15:46:14 EST
Upstream ant uses org.apache.ant groupId not ant groupId. You would have to chase down the places where ant is used as groupId and fix it to be org.apache.ant.
Comment 11 Orion Poplawski 2010-12-07 16:05:10 EST
Thanks!  Fixed.

Note You need to log in before you can comment on or make changes to this bug.