Bug 660971 - FTBFS dopewars-1.5.12-9.1033svn.fc13
FTBFS dopewars-1.5.12-9.1033svn.fc13
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dopewars (Show other bugs)
rawhide
i386 Linux
high Severity high
: ---
: ---
Assigned To: Susi Lehtola
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: F15FTBFS
  Show dependency treegraph
 
Reported: 2010-12-07 13:31 EST by FTBFS
Modified: 2011-06-16 15:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-10 07:11:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (473.67 KB, text/plain)
2010-12-07 13:31 EST, FTBFS
no flags Details
build.log (45.16 KB, text/plain)
2010-12-07 13:31 EST, FTBFS
no flags Details
mock.log (960 bytes, text/plain)
2010-12-07 13:31 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-12-07 13:31:47 EST
dopewars-1.5.12-9.1033svn.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-12-07 13:31:50 EST
Created attachment 466583 [details]
root.log


root.log for i386
Comment 2 FTBFS 2010-12-07 13:31:52 EST
Created attachment 466584 [details]
build.log


build.log for i386
Comment 3 FTBFS 2010-12-07 13:31:53 EST
Created attachment 466585 [details]
mock.log


mock.log for i386
Comment 4 Susi Lehtola 2010-12-10 07:11:19 EST
Built succesfully in rawhide without any modifications to the spec file.
http://koji.fedoraproject.org/koji/taskinfo?taskID=2656649
Comment 5 Matt Domsch 2010-12-10 09:56:36 EST
Looks to me like a race condition in the upstream project.  the failure for me looks like:

(cd .libs && rm -f libsound_esd.so && ln -s libsound_esd.so.0.0.0 libsound_esd.so)
rm -fr  .libs/libsound_sdl.a
ranlib .libs/libsound_sdl.a
ranlib: '.libs/libsound_sdl.a': No such file
make[3]: *** [libsound_sdl.la] Error 1
make[3]: *** Waiting for unfinished jobs....

So, it deletes the file, then runs ranlib on the (missing) file, and errors out.  Odd that it would do so.  Take it up with upstream?

Note You need to log in before you can comment on or make changes to this bug.