Bug 661026 - FTBFS perl-QWizard-3.15-5.fc14
FTBFS perl-QWizard-3.15-5.fc14
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-QWizard (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Wes Hardaker
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: F15FTBFS
  Show dependency treegraph
 
Reported: 2010-12-07 13:44 EST by FTBFS
Modified: 2011-06-16 15:05 EDT (History)
3 users (show)

See Also:
Fixed In Version: perl-QWizard-3.15-7.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-30 12:26:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (47.13 KB, text/plain)
2010-12-07 13:44 EST, FTBFS
no flags Details
build.log (15.42 KB, text/plain)
2010-12-07 13:44 EST, FTBFS
no flags Details
mock.log (885 bytes, text/plain)
2010-12-07 13:44 EST, FTBFS
no flags Details
root.log (59.56 KB, text/plain)
2010-12-07 13:44 EST, FTBFS
no flags Details
build.log (15.50 KB, text/plain)
2010-12-07 13:44 EST, FTBFS
no flags Details
mock.log (893 bytes, text/plain)
2010-12-07 13:45 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-12-07 13:44:51 EST
perl-QWizard-3.15-5.fc14.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-12-07 13:44:54 EST
Created attachment 466882 [details]
root.log


root.log for i386
Comment 2 FTBFS 2010-12-07 13:44:55 EST
Created attachment 466883 [details]
build.log


build.log for i386
Comment 3 FTBFS 2010-12-07 13:44:56 EST
Created attachment 466884 [details]
mock.log


mock.log for i386
Comment 4 FTBFS 2010-12-07 13:44:58 EST
Created attachment 466885 [details]
root.log


root.log for x86_64
Comment 5 FTBFS 2010-12-07 13:44:59 EST
Created attachment 466886 [details]
build.log


build.log for x86_64
Comment 6 FTBFS 2010-12-07 13:45:01 EST
Created attachment 466887 [details]
mock.log


mock.log for x86_64
Comment 7 Ralf Corsepius 2010-12-14 12:19:31 EST
Wes, several issues

* the patch you applied yesterday:

Commit 6d967c0a7120229a65652c923ec83022fa5162d1
Author: Wes Hardaker <opensource@hardakers.net>
Date:   Fri Dec 10 13:35:39 2010 -0800

    require perl(CGI) for building since make test requires it

... doesn't seem right to me.

Adding BR: perl(CGI) definitely is correct, but R: perl(CGI) seems rather questionable, because there is no hard dependency on perl(CGI).

* You missed to add a changelog entry to the spec.

* Please close this BZ when you believe it is fixed.
Comment 8 Wes Hardaker 2011-01-13 16:21:14 EST
Technically many of the packages are optional.  But the package itself isn't useful without pulling in the other ones.  IMHO, since the package is readily available we should pull it in because the features won't work without it.  The optionality in the base is there to ensure people that don't have a complete set of packages don't need them if they're building by hand.  For people with distributions that have all the components, it makes more sense to include them all.
Comment 9 Fedora Update System 2011-01-13 16:41:18 EST
perl-QWizard-3.15-7.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/perl-QWizard-3.15-7.el5
Comment 10 Fedora Update System 2011-01-14 11:58:18 EST
perl-QWizard-3.15-7.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update perl-QWizard'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/perl-QWizard-3.15-7.el5
Comment 11 Fedora Update System 2011-01-30 12:25:52 EST
perl-QWizard-3.15-7.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.