Bug 661045 - FTBFS tsclient-2.0.2-7.fc13
FTBFS tsclient-2.0.2-7.fc13
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: tsclient (Show other bugs)
15
All Linux
high Severity high
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: F15FTBFS
  Show dependency treegraph
 
Reported: 2010-12-07 13:48 EST by FTBFS
Modified: 2014-06-18 05:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-23 15:33:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (986.73 KB, text/plain)
2010-12-07 13:48 EST, FTBFS
no flags Details
build.log (43.83 KB, text/plain)
2010-12-07 13:48 EST, FTBFS
no flags Details
mock.log (871 bytes, text/plain)
2010-12-07 13:48 EST, FTBFS
no flags Details
root.log (1.37 MB, text/plain)
2010-12-07 13:48 EST, FTBFS
no flags Details
build.log (43.25 KB, text/plain)
2010-12-07 13:48 EST, FTBFS
no flags Details
mock.log (956 bytes, text/plain)
2010-12-07 13:48 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-12-07 13:48:14 EST
tsclient-2.0.2-7.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-12-07 13:48:18 EST
Created attachment 466982 [details]
root.log


root.log for i386
Comment 2 FTBFS 2010-12-07 13:48:19 EST
Created attachment 466983 [details]
build.log


build.log for i386
Comment 3 FTBFS 2010-12-07 13:48:21 EST
Created attachment 466984 [details]
mock.log


mock.log for i386
Comment 4 FTBFS 2010-12-07 13:48:23 EST
Created attachment 466985 [details]
root.log


root.log for x86_64
Comment 5 FTBFS 2010-12-07 13:48:24 EST
Created attachment 466986 [details]
build.log


build.log for x86_64
Comment 6 FTBFS 2010-12-07 13:48:26 EST
Created attachment 466987 [details]
mock.log


mock.log for x86_64
Comment 7 Niels de Vos 2011-03-26 15:09:05 EDT
Fedora 15 has the following contents in dead.package:

Removed due to dead upstream and superior alternatives
E.g. Remmina and gnome-rdp


This bug can therefore be closed WONTFIX imho.
Comment 8 Jason Montleon 2011-04-11 11:26:20 EDT
I have not used gnome-rdp or remmina before, but I tried installing both:
yum -y install gnome-rdp ends in:
Error: Package: gnome-rdp-0.2.3-6.fc12.x86_64 (fedora)
           Requires: mono(Mono.Data.SqliteClient) = 2.0.0.0
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I have these installed:
remmina-plugins-common-0.9.2-2.fc15.x86_64
remmina-0.9.3-3.fc15.x86_64
remmina-plugins-rdp-0.9.2-2.fc15.x86_64
                              
and remmina still only shows the SFTP and SSH plugins as installed and still only allows for creating SSH and SFTP connections.


tsclient appears to build and work with very little change. Any one of the programs would probaby be fine if they worked, but so far this is the simplest solution I found:

looks like old was:
NotifyNotification* notify_notification_new 	( 	const gchar *  	summary,
		const gchar *  	body,
		const gchar *  	icon,
		GtkWidget *  	attach	 
	) 	

and new:
NotifyNotification * notify_notification_new            (const char *summary,
                                                         const char *body,
                                                         const char *icon);

so:

diff -uNr tsclient-2.0.2 tsclient-2.0.2-new
diff -uNr tsclient-2.0.2/src/plugins/default/tsc-rdp-connection.c tsclient-2.0.2-new/src/plugins/default/tsc-rdp-connection.c
--- tsclient-2.0.2/src/plugins/default/tsc-rdp-connection.c	2008-11-26 16:31:35.000000000 -0500
+++ tsclient-2.0.2-new/src/plugins/default/tsc-rdp-connection.c	2011-04-11 09:06:54.000000000 -0400
@@ -52,7 +52,7 @@
 				   tsc_connection_get_name (TSC_CONNECTION (connection)));
 	body = g_strdup_printf (_("You are connected to '%s' in fullscreen mode.  Use Control+Alt+Enter to switch to and from windowed mode."), tsc_connection_get_name (TSC_CONNECTION (connection)));
 	
-	n = notify_notification_new (summary, body, GTK_STOCK_DIALOG_INFO, NULL);
+	n = notify_notification_new (summary, body, GTK_STOCK_DIALOG_INFO);
 	g_free (summary);
 	g_free (body);
 	
diff -uNr tsclient-2.0.2/src/plugins/default/tsc-vnc-connection.c tsclient-2.0.2-new/src/plugins/default/tsc-vnc-connection.c
--- tsclient-2.0.2/src/plugins/default/tsc-vnc-connection.c	2008-11-26 16:19:02.000000000 -0500
+++ tsclient-2.0.2-new/src/plugins/default/tsc-vnc-connection.c	2011-04-11 09:10:58.000000000 -0400
@@ -39,7 +39,7 @@
 				   tsc_connection_get_name (TSC_CONNECTION (connection)));
 	body = g_strdup_printf (_("You are connected to '%s' in fullscreen mode.  Use F8 to switch to and from windowed mode."), tsc_connection_get_name (TSC_CONNECTION (connection)));
 
-	n = notify_notification_new (summary, body, GTK_STOCK_DIALOG_INFO, NULL);
+	n = notify_notification_new (summary, body, GTK_STOCK_DIALOG_INFO);
 	g_free (summary);
 	g_free (body);
Comment 9 Jason Montleon 2011-04-11 12:06:52 EDT
actually remmina works; looks like when you run it it stays in the notification area, so once i fully closed it and restarted the program I had rdp connections available, so there is at least one working alternative.
Comment 10 Filipe Rosset 2012-04-23 15:33:34 EDT
I'm closing this bug since tsclient was removed due to dead upstream and at least two superior alternatives (remmina and gnome-rdp)

Note You need to log in before you can comment on or make changes to this bug.