Bug 661107 - ! LaTeX Error: \cftchapfont undefined.
! LaTeX Error: \cftchapfont undefined.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: doxygen (Show other bugs)
rawhide
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 660736 660738 660750 660773 660788 660801 660812 660816 660817 660835 660838 660863 660874 660885 660906 660912 660915 660919 660934 660939 660941 660973 660977 660982 660993 661004 661006 661013 661016 661019 661031 661053 661064 661084 661089 661091
  Show dependency treegraph
 
Reported: 2010-12-07 14:40 EST by Steve Traylen
Modified: 2011-01-19 10:46 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-17 07:09:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
doxygen timestamp patch for doxygen 1.7.3. (2.46 KB, patch)
2011-01-14 16:56 EST, Steve Traylen
no flags Details | Diff

  None (edit)
Description Steve Traylen 2010-12-07 14:40:39 EST
There are a load of FTBFS bugs just created for packages using doxygen
e.g.
bug #661031

which shows:

(/usr/share/texmf/tex/latex/tocloft/tocloft.sty
Package tocloft Note: The document has section divisions.
)
! LaTeX Error: \cftchapfont undefined.
See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.20 \renewcommand{\cftchapfont}
                                {%
? 
! Emergency stop.
 ...                                              

l.20 \renewcommand{\cftchapfont}
                                {%
!  ==> Fatal error occurred, no output PDF file produced!

The other item that makes me think doxygen is implicated is:

http://sourceforge.net/mailarchive/message.php?msg_name=4CF21BD2.6090001%40cs.unipr.it
Comment 1 Mattias Ellert 2011-01-07 04:05:19 EST
doxygen 1.7.3 has changed \renewcommand{\cftchapfont} to \providecommand{\cftchapfont}:

http://doxygen.svn.sourceforge.net/viewvc/doxygen/trunk/src/latexgen.cpp?r1=750&r2=752

So it could possibly fix this issue.
Comment 2 Steve Traylen 2011-01-14 05:24:38 EST
From debian

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=606276

doxygen 1.7.3 looks to have fixed this.

Please could you update from 1.7.2.

Steve.
Comment 3 Steve Traylen 2011-01-14 16:56:57 EST
Created attachment 473600 [details]
doxygen timestamp patch for doxygen 1.7.3.

Hi, 
This is updated patch to doxygen-1.6.2-timestamp.patch to allow 1.7.3 to build.

Steve.
Comment 4 Ngo Than 2011-01-17 07:09:42 EST
it's fixed in rawhide
Comment 5 Steve Traylen 2011-01-17 07:25:04 EST
Thankyou, 

I confirm myproxy now builds okay as a scratch with 1.7.3.

http://koji.fedoraproject.org/koji/taskinfo?taskID=2725757

Steve.
Comment 6 Hans Ulrich Niedermann 2011-01-19 10:34:10 EST
Can we expect fixed F14 updates to the doxygen package as well? I still have an F14 FTBFS bug 661084 open due to this bug.
Comment 7 Hans Ulrich Niedermann 2011-01-19 10:46:39 EST
(In reply to comment #6)
> Can we expect fixed F14 updates to the doxygen package as well? I still have an
> F14 FTBFS bug 661084 open due to this bug.

Something is not right in what I wrote here. Scratch builds of the F15 package succeed for dist-f14 and dist-f14, so something else must have changed there, and doxygen does not prevent my builds anymore.

I will consider this issue closed now, unless proven otherwise at a later time.

Note You need to log in before you can comment on or make changes to this bug.