Bug 661111 - Labels, Texts, and Tables in sm-gui have no handle to be read by automation
Summary: Labels, Texts, and Tables in sm-gui have no handle to be read by automation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: beta
: ---
Assignee: Justin Harris
QA Contact: Jeff Weiss
URL:
Whiteboard:
Depends On:
Blocks: Entitlement-Beta
TreeView+ depends on / blocked
 
Reported: 2010-12-07 19:51 UTC by Jeff Weiss
Modified: 2014-11-09 22:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
subscription-manager-0.93.3-1.git.0.a79d99d.fc14.x86_64
Last Closed: 2011-05-19 13:38:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:0611 normal SHIPPED_LIVE new package: subscription-manager 2011-05-18 17:56:21 UTC

Description Jeff Weiss 2010-12-07 19:51:14 UTC
Description of problem:
Error dialogs in rhsm-gui (for instance, register with invalid user/pw), there's no at-spi object name that will allow me to retrieve the error message.

Automation needs to be able to distinguish between different errors. 

"Unable to register the system.

 Invalid username or password

Please see /var/log/rhsm/rhsm.log"

There's a "label" object with the above text, but the name of the object is the same as the text, so I have no handle to retrieve it by.  Not sure what the solution is for this, but the error message needs to be retrievable by a known name.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 2 Jeff Weiss 2010-12-08 13:10:30 UTC
I found a workaround for this issue:

ldtp.getobjectproperty("Error","lbl[A-Z a-z]*","label")

I'll reopen this if I hit other Error dialogs that I can't workaround to get the error text.

Comment 3 Jeff Weiss 2010-12-09 18:19:53 UTC
Reopening - There's actually a bunch of UI controls that i'll need the automation to interact with, that have no at-spi name.

1) There are 2 tables on each of the 3 tabs, plus the "Become Compliant" window.  None of them have names.
2) Textboxes on "My Installed Software" at bottom, next to Product/Compliance/Subscription.
3) System name/ Next update texts at upper right.
4) Radio buttons and date selectors' names are calculated values (containing a date that will change)
5) Textboxes in HTTP Proxy dialog.

Comment 4 Jeff Weiss 2010-12-09 20:13:04 UTC
6) the textbox next to "contain the text" on the "All Available Subscriptions" tab.

Comment 5 Jeff Weiss 2010-12-09 22:42:00 UTC
I found this tool in an effort to work around this problem (which has failed so far, but the tools is nice) 

http://live.gnome.org/Accerciser

It runs tests to show the kinds of accessibility problems I'm seeing.

Comment 6 Justin Harris 2010-12-17 15:44:29 UTC
I think that I got most all of the requested labels in, and verified that they were showing up with Accerciser (which works pretty well, btw).  Kick this bug back to me if I missed anything or if you need other widgets labelled.

Comment 7 Jeff Weiss 2010-12-20 20:46:31 UTC
Justin - try using the "AT-SPI Validator" tab in accerciser.  It shows you missing names/labels, and some other stuff that i'm not quite sure what it means, but sounds like it should be fixed.  There's a couple text boxes still without name/label.

Comment 8 Jeff Weiss 2010-12-20 22:15:46 UTC
<jweiss> jharris: there's some inconsistency with the ui object names - not a big deal, but Subscribe is just called "Subscribe" but Unsubscribe is called "Unsubscribe Button"
 i suppose it is fine either way as long as it's consistent.  But I believe that other apps do not use types in the names.  And a quick glance around http://library.gnome.org/devel/accessibility-devel-guide/nightly/ seems to confirm that.  Kinda makes sense because types are already known to the accessibility layer.

Comment 9 Jeff Weiss 2011-01-24 19:40:43 UTC
This seems to be fixed now, I haven't checked all the controls, but I'll reopen if I find anything.

Comment 10 errata-xmlrpc 2011-05-19 13:38:00 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0611.html


Note You need to log in before you can comment on or make changes to this bug.