Bug 661161 - kdf (KDiskFree) fails to display information for devices with special characters in their names
kdf (KDiskFree) fails to display information for devices with special charact...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdeutils (Show other bugs)
14
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-07 18:20 EST by Peter Trenholme
Modified: 2011-06-03 05:39 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-03 05:38:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Trenholme 2010-12-07 18:20:46 EST
Description of problem:
The kdf application fails to display disk usage information for devices containing special characters (spaces, comma, single quotes, etc.) in the device name.

Version-Release number of selected component (if applicable):
Qt: 4.7.1
KDE Development Platform: 4.5.3 (KDE 4.5.3)
KDiskFree: v0.11


How reproducible:
Every time

Steps to Reproduce:
1.Mount a device with a name containing (e.g) a blank
2.Look in the kdf display
3.
  
Actual results:
No display of the special device disk usage

Expected results:
Display of device's usage

Additional info:
With the following loop devices mounted:
$ mount | grep loop
/ISO/1635 - The Eastern Front.iso on /mnt/ISO/1635 - The Eastern Front type iso9660 (ro,loop=/dev/loop0)
/ISO/At All Costs.iso on /mnt/ISO/At All Costs type iso9660 (ro,loop=/dev/loop1)
/ISO/Cryoburn.iso on /mnt/ISO/Cryoburn type iso9660 (ro,loop=/dev/loop2)
/ISO/Ghost.iso on /mnt/ISO/Ghost type iso9660 (ro,loop=/dev/loop4)
/ISO/Looking Glass.iso on /mnt/ISO/Looking Glass type iso9660 (ro,loop=/dev/loop5)
/ISO/Mission of Honor.iso on /mnt/ISO/Mission of Honor type iso9660 (ro,loop=/dev/loop6)
/ISO/Storm from the Shadows.iso on /mnt/ISO/Storm from the Shadows type iso9660 (ro,loop=/dev/loop7)
/ISO/The Best of Jim Baens Universe.iso on /mnt/ISO/The Best of Jim Baens Universe type iso9660 (ro,loop=/dev/loop8)
/ISO/The Claws that Catch.iso on /mnt/ISO/The Claws that Catch type iso9660 (ro,loop=/dev/loop9)
/ISO/The Far Side of the Stars.iso on /mnt/ISO/The Far Side of the Stars type iso9660 (ro,loop=/dev/loop10)
/ISO/The Spider.iso on /mnt/ISO/The Spider type iso9660 (ro,loop=/dev/loop11)
/ISO/This Scepter'd Isle.iso on /mnt/ISO/This Scepter'd Isle type iso9660 (ro,loop=/dev/loop12)
/ISO/Windrider's Oath.iso on /mnt/ISO/Windrider's Oath type iso9660 (ro,loop=/dev/loop13)

the kdf display shows only the Cyroburn and Ghost devices, and one device called "iso9660" from, I think, the "Windrider's Oath" ISO image file.

F.Y.I.: the df terminal program has no problem with those devices.

Note that this is, mostly, a cosmetic issue (hence my "low severity" rating) since the free space in any read-only image is, of course, 0.
Comment 1 Peter Trenholme 2011-06-02 19:44:43 EDT
I'd forgotten this one, but I just checked kdf on Fedora 15, and the problem is fixed there. So I presume that the KDE developers fixed it for, at least, the latest release of KDE.
Comment 2 Kevin Kofler 2011-06-03 05:39:34 EDT
Fedora 14 has been upgraded to the same version of KDE as Fedora 15, so I guess this is fixed there too.

Thanks for the update.

Note You need to log in before you can comment on or make changes to this bug.