Bug 661212 - Probe Suite UI: "Probes" tab does not show probe suite name in header
Probe Suite UI: "Probes" tab does not show probe suite name in header
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
urgent Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Šimon Lukašík
: Regression
Depends On:
Blocks: sat54-errata
  Show dependency treegraph
 
Reported: 2010-12-08 02:09 EST by Xixi
Modified: 2011-03-17 10:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Consequence rhn/monitoring/config/ProbeSuiteListProbes.do page does not display the Probe Suite name Result ProbeSuiteListProbes.do page correctly displays the Probe Suite name
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-17 10:10:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xixi 2010-12-08 02:09:04 EST
Description of problem:
rhn/monitoring/config/ProbeSuiteListProbes.do page, which lists all Monitoring Probes in a Probe Suite, does not show the Probe Suite name but instead just "Probes in".

Version-Release number of selected component (if applicable):
Red Hat Network (RHN) Satellite 5.3.0

How reproducible:
Always.

Steps to Reproduce:
1. Have a 5.3 (or 5.4) Satellite with Monitoring enabled and create a Probe Suite and at least 1 Probe in it.
2. Go to Monitoring -> Probe Suites -> Probes tab (rhn/monitoring/config/ProbeSuiteListProbes.do)

Actual results:
Header shows "Probes in", with no suite name.

Expected results:
Header shows "Probes in <probe suite name>".

Additional info:
This appears to be a regression since Satellite 5.2 does not have the issue.
Comment 1 Xixi 2010-12-08 03:04:08 EST
Main difference that I could see from 5.2->5.3 code is that com.redhat.rhn.frontend.action.monitoring.ProbeSuiteListSetupAction now extends RhnAction implements Listable vs. before where it extends BaseSetListAction.

Maybe the probeSuite parameter is not being set up in the request properly?
Comment 2 Tomas Lestach 2011-01-05 05:42:51 EST
Setting the suite name ...

commit: e4c36d49bca5734c255dcc3ab08729e791790a7f
Comment 6 Tomas Lestach 2011-02-14 09:58:58 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Consequence
rhn/monitoring/config/ProbeSuiteListProbes.do page does not display the Probe Suite name

Result
ProbeSuiteListProbes.do page correctly displays the Probe Suite name
Comment 7 Šimon Lukašík 2011-02-23 03:30:48 EST
Taking QA contact.
Comment 8 Šimon Lukašík 2011-02-23 06:14:27 EST
Switching to VERIFIED.

Verified against:
spacewalk-java-1.2.39-36.el5sat
Comment 9 errata-xmlrpc 2011-03-17 10:10:39 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0362.html

Note You need to log in before you can comment on or make changes to this bug.