Bug 661220 - Providing native systemd file for upcoming F15 Feature Systemd
Providing native systemd file for upcoming F15 Feature Systemd
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: watchdog (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks: SysVtoSystemd
  Show dependency treegraph
 
Reported: 2010-12-08 03:16 EST by Michał Piotrowski
Modified: 2012-03-14 13:07 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-14 13:07:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
watchdog.service (148 bytes, text/plain)
2010-12-08 03:22 EST, Michał Piotrowski
no flags Details

  None (edit)
Description Michał Piotrowski 2010-12-08 03:16:39 EST
The attached file is a native systemd file for upcoming F15 Feature [1]

Please read [2] on how to packaging and installing systemd Service files.

To learn more about Systemd daemon see [3].

To view old SysV with the new Systemd site by site see for your component see [4]

If you have any question dont hesitate to ask them on this bug report.

1.http://fedoraproject.org/wiki/Features/systemd

2.https://fedoraproject.org/wiki/Systemd_Packaging_Draft

3.http://0pointer.de/public/systemd-man/daemon.html

4.https://fedoraproject.org/wiki/User:Johannbg/QA/Systemd/compatability
Comment 1 Michał Piotrowski 2010-12-08 03:22:58 EST
Created attachment 467410 [details]
watchdog.service

I didn't added /etc/sysconfig/watchdog , because it doesn't provide any command line options. If you think that --verbose option is needed, then please add it to ExecStart= or as OPTIONS variable to /etc/sysconfig/watchdog.
Comment 2 Richard W.M. Jones 2011-01-17 09:01:01 EST
I've added the watchdog.service file in Rawhide.  However I
didn't make any changes to the spec file %pre/%post etc. so
at the moment the service file is just installed, not used.

http://koji.fedoraproject.org/koji/taskinfo?taskID=2725958
Comment 3 Jon Ciesla 2012-02-13 14:35:10 EST
Richard, any objection to my completing this migration?
Comment 4 Jon Ciesla 2012-03-14 12:22:40 EDT
Ping?
Comment 5 Richard W.M. Jones 2012-03-14 12:29:44 EDT
(In reply to comment #4)
> Ping?

Sorry, somehow I missed comment 3.  Please complete this
and any other systemd migrations of mine that you know about.
Comment 6 Jon Ciesla 2012-03-14 13:07:56 EDT
Done, thanks all!

I didn't see any more of yours, at least as filed bugs, but if you get more and want a hand, CC me on the BZ.

Note You need to log in before you can comment on or make changes to this bug.