Bug 661230 - Providing native systemd file for upcoming F15 Feature Systemd
Summary: Providing native systemd file for upcoming F15 Feature Systemd
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wpa_supplicant   
(Show other bugs)
Version: rawhide
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: SysVtoSystemd
TreeView+ depends on / blocked
 
Reported: 2010-12-08 09:20 UTC by Michał Piotrowski
Modified: 2011-09-30 19:35 UTC (History)
3 users (show)

Fixed In Version: wpa_supplicant-0.7.3-11.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-30 19:35:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
wpa_supplicant.service (317 bytes, text/plain)
2010-12-08 09:28 UTC, Michał Piotrowski
no flags Details
Native systemd service file wpa_supplicant (305 bytes, text/plain)
2011-07-18 17:25 UTC, Jóhann B. Guðmundsson
no flags Details
Spec file patch for wpa_supplicant (1.55 KB, text/plain)
2011-07-26 21:23 UTC, Jóhann B. Guðmundsson
no flags Details

Description Michał Piotrowski 2010-12-08 09:20:10 UTC
The attached file is a native systemd file for upcoming F15 Feature [1]

Please read [2] on how to packaging and installing systemd Service files.

To learn more about Systemd daemon see [3].

To view old SysV with the new Systemd site by site see for your component see [4]

If you have any question dont hesitate to ask them on this bug report.

1.http://fedoraproject.org/wiki/Features/systemd

2.https://fedoraproject.org/wiki/Systemd_Packaging_Draft

3.http://0pointer.de/public/systemd-man/daemon.html

4.https://fedoraproject.org/wiki/User:Johannbg/QA/Systemd/compatability

Comment 1 Michał Piotrowski 2010-12-08 09:28:49 UTC
Created attachment 467424 [details]
wpa_supplicant.service

I didn't tested this service as I do with other services, because I don't use it and don't know how to configure it. It's a blind conversion, so please keep this in mind while testing.

Removal of "-c /etc/wpa_supplicant/wpa_supplicant.conf" would be good if it's possible.

Comment 2 Michał Piotrowski 2010-12-08 09:34:13 UTC
BTW. Requires=dbus.socket may also be needed

Comment 4 Dan Williams 2011-07-18 17:08:08 UTC
We'll also want "-u" in the daemon arguments to enable the D-Bus interface.

Comment 5 Jóhann B. Guðmundsson 2011-07-18 17:10:44 UTC
Note there is some discussion happening upstream so Dan you might want to chime
into that.. 

http://lists.freedesktop.org/archives/systemd-devel/2011-July/002896.html

Comment 6 Jóhann B. Guðmundsson 2011-07-18 17:25:58 UTC
Created attachment 513658 [details]
Native systemd service file wpa_supplicant

Added network.target to the after line and the -u daemon option

Comment 7 Jóhann B. Guðmundsson 2011-07-26 21:23:49 UTC
Created attachment 515375 [details]
Spec file patch for wpa_supplicant

Comment 8 Fedora Update System 2011-09-08 18:42:21 UTC
wpa_supplicant-0.7.3-10.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/wpa_supplicant-0.7.3-10.fc16

Comment 9 Fedora Update System 2011-09-08 20:48:48 UTC
Package wpa_supplicant-0.7.3-10.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wpa_supplicant-0.7.3-10.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/wpa_supplicant-0.7.3-10.fc16
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2011-09-09 16:29:00 UTC
wpa_supplicant-0.7.3-11.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/wpa_supplicant-0.7.3-11.fc16

Comment 11 Fedora Update System 2011-09-30 19:34:57 UTC
wpa_supplicant-0.7.3-11.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.