Bug 661241 - Providing native systemd file for upcoming F15 Feature Systemd
Providing native systemd file for upcoming F15 Feature Systemd
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: wesnoth (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Jon Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks: SysVtoSystemd
  Show dependency treegraph
 
Reported: 2010-12-08 04:43 EST by Michał Piotrowski
Modified: 2012-01-31 21:05 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-31 21:05:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
wesnothd.service (230 bytes, text/plain)
2010-12-08 04:46 EST, Michał Piotrowski
no flags Details

  None (edit)
Description Michał Piotrowski 2010-12-08 04:43:59 EST
The attached file is a native systemd file for upcoming F15 Feature [1]

Please read [2] on how to packaging and installing systemd Service files.

To learn more about Systemd daemon see [3].

To view old SysV with the new Systemd site by site see for your component see [4]

If you have any question dont hesitate to ask them on this bug report.

1.http://fedoraproject.org/wiki/Features/systemd

2.https://fedoraproject.org/wiki/Systemd_Packaging_Draft

3.http://0pointer.de/public/systemd-man/daemon.html

4.https://fedoraproject.org/wiki/User:Johannbg/QA/Systemd/compatability
Comment 1 Michał Piotrowski 2010-12-08 04:46:53 EST
Created attachment 467428 [details]
wesnothd.service

There is a small problem after stopping service

systemctl status wesnothd.service
wesnothd.service - Wesnoth game server
	  Loaded: loaded (/lib/systemd/system/wesnothd.service)
	  Active: failed since Wed, 08 Dec 2010 10:42:47 +0100; 897ms ago
	 Process: 6535 (/usr/sbin/wesnothd --daemon $WESNOTHD_OPTIONS, code=exited, status=0/SUCCESS)
	Main PID: 6536 (code=exited, status=143)
	  CGroup: name=systemd:/system/wesnothd.service

Don't know why it's "Active: failed".
Comment 2 Michał Piotrowski 2010-12-09 03:43:58 EST
This service should start after network.target
After=syslog.target network.target

Note You need to log in before you can comment on or make changes to this bug.