Bug 661282 - restarting daemons for sysconfig changes
Summary: restarting daemons for sysconfig changes
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: rawhide
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-08 12:05 UTC by Marcela Mašláňová
Modified: 2011-03-04 04:09 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-04 04:09:43 UTC
Type: ---


Attachments (Terms of Use)

Description Marcela Mašláňová 2010-12-08 12:05:38 UTC
I had bug reports about restarting daemon because of changes in sysconfig file. Imagine that you have cron daemon running on cluster or with home's through LDAP. After every restart is possible that something goes wrong like LDAP user's won't be found. Also I don't think it's wise reloading all daemons. Some could take new options immediately, some after restart,... I will have troubles only with cron, but what about more important services, where system administrator have to restart daemons?

Please revert this behaviour.

Reproducer:
change /etc/sysconfig/crond
systemctl --system daemon-reload
service crond restart

Version:
systemd-15-1.fc15.x86_64

Comment 1 Lennart Poettering 2011-01-04 23:35:34 UTC
Hmm, we probably should read that information when spawning a service, not already when loading the configuration.

Comment 2 Lennart Poettering 2011-03-04 04:09:43 UTC
systemd git now reads those env config files at process spwan time, not already when systemd reads its own configuration. This should resolve the issue.

Upload to F15 follows shortly.


Note You need to log in before you can comment on or make changes to this bug.