Bug 661322 - Unable to soft-unblock WLAN
Summary: Unable to soft-unblock WLAN
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 14
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: John Feeney
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-08 14:59 UTC by Jorn Amundsen
Modified: 2013-01-10 07:33 UTC (History)
8 users (show)

Fixed In Version: kernel-2.6.35.14-100.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-30 00:31:10 UTC
Type: ---


Attachments (Terms of Use)

Description Jorn Amundsen 2010-12-08 14:59:21 UTC
Description of problem:
After booting and logging into an account, it is impossible to enable wireless in the notebook (Acer Aspire 1830T) by typing <Fn>-<F3> key to toggle wireless. The Fn-F3 keystroke successfully toggles Bluetooth on and off, but the WLAN consistently stays at


  [root@localhost ~]# rfkill list 0
  0: acer-wireless: Wireless LAN
          Soft blocked: yes
          Hard blocked: no

, making it impossible to turn on wireless in KNetworkManager.

Version-Release number of selected component (if applicable):

kernel-2.6.35.9-64.fc14.x86_64
kernel-2.6.34.7-63.fc13.x86_64

How reproducible: every time


Steps to Reproduce:
1. boot
2. login
3. attempt to toggle KNetworkManager "Enable Wireless" checkbox
  
Actual results:

Wireless LAN soft-blocked

Expected results:

Wireless LAN Soft *and* Hard *unblocked.

Additional info:

Similar behavior is reported in Bug 595931 and 597007. In 597007 the problem is tracked to the acer_wmi module wmi alias reading,

  [root@localhost ~]# modinfo acer_wmi
  filename:       /lib/modules/2.6.35.9-64.fc14.x86_64/kernel/drivers/platform/x86/acer-wmi.ko
  alias:          wmi:6AF4F258-B401-42fd-BE91-3D4AC2D7C0D3
  alias:          wmi:67C3371D-95A3-4C37-BB61-DD47B491DAAB

, while the first alias should read *should* read (42fd -> 42FD)

    wmi:6AF4F258-B401-42FD-BE91-3D4AC2D7C0D3

,for consistency with the /sys/class/6AF4F258-B401-42FD-BE91-3D4AC2D7C0D3 directory.

It appears this error is reintroduced in the aforementioned kernels.

Comment 1 Dave Jones 2011-10-11 18:33:14 UTC
applied to git, will be in the next build.
apologies for the delay.

Comment 2 Fedora Update System 2011-10-21 20:46:34 UTC
kernel-2.6.35.14-100.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/kernel-2.6.35.14-100.fc14

Comment 3 Fedora Update System 2011-10-22 08:26:42 UTC
Package kernel-2.6.35.14-100.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-2.6.35.14-100.fc14'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-14747
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2011-10-30 00:31:10 UTC
kernel-2.6.35.14-100.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 manfredgrabherr 2011-10-30 21:35:03 UTC
Not sure this is the same bug, but I just upgraded from kernel-2.6.35.14-97.fc14 to kernel-2.6.35.14-100.fc14, and wireless stopped working, ifconfig does not see my wireless network card. With kernel 14-97, it reports:

eth1      Link encap:Ethernet  HWaddr 68:A3:C4:2C:A7:20  
          inet addr:192.168.1.5  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::6aa3:c4ff:fe2c:a720/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:518127 errors:0 dropped:0 overruns:0 frame:78421
          TX packets:264645 errors:6 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:776220522 (740.2 MiB)  TX bytes:20699298 (19.7 MiB)
          Interrupt:17 

With 14-100, there is nothing listed. It's a Dell inspiron N7010 laptop, not sure about the exact wireless network chipset. I reverted back to the old (97) kernel for now and it works just fine. Any help is appreciated.


Note You need to log in before you can comment on or make changes to this bug.