Bug 66134 - Installer crashes while just after/during installing openjade
Installer crashes while just after/during installing openjade
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-05 04:39 EDT by Need Real Name
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-12 12:59:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Comment (70.22 KB, text/plain)
2002-06-05 04:50 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-06-05 04:39:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.0.3705)

Description of problem:
This has been an odd bug.  The first time I attempted to install Redhat, the 
installer crashed about 1/2 way through, just after/during installing 
openjade.  I naturally thought this was a fluke, so I tried again, and 
received the same error in the exact same place.  Then I remembered that I was 
using a CD-R, so I thought the CD was the problem and burned another.  This 
time, it got past the openjade spot, but hung just a few packets from 
completion (didn't catch the exact point).  So, I figured that I also had a 
bad 2nd CD as well, and burned another of it.  It crashed at the openjade 
point again.  Next, I thought my download was to blame, so I downloaded both 
CDs again and burned yet another copy of each.    The next time I tried, it 
crashed in the same spot as before, at the openjade point.  At this point I 
logged into bugzilla and read through some people with similar problems.  I 
also ran the checksum, which came out perfectly fine.  I noticed one person 
said he burned a CD at a slower speed, and this solved the problem, so I tried 
that, too.  However, I received the same error.  This leads me to believe that 
this error is a bug, for 2 reasons:
1.  Other people have had this same error at the same point.  The odds of this 
happening by a faulty burn are quite high.
2.  I used FOUR DIFFERENT CDs.  The odds of the same error at the same point 
occuring due to a replicated erroneous burn are also extremely slim.
Oh well, I hope you can help.  I was going to be a former Windows user, but 
now I'm not so sure.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Burn the installation disk
2. Run the installer


Actual Results:  I receive the same error

Additional info:

OK - here is the hardware config:

* Pentium 4 2.0 GHz
* 512 MB DDR RAM
* Soundblaster Audigy Gamer
* Visiontek XTASY 6964 Geforce 3 Ti500
* 3 hard drives - 80 GB Samsung (Windows disk), 15 GB Maxtor (also Windows 
disk), and 6 GB Quantum Bigfoot (would-be Linux disk)
* Acer Benq 48x12x48 CD-R/RW

* Note: while typing this up, I had an idea - I burned the disks without 
closing the sessions (old habit), and since the errors come just after the 
half-way point of the installation (or at the theoretical end of the first 
disk), perhaps this is the cause of the problem.  I will respond saying 
whether this has an effect.
Comment 1 Need Real Name 2002-06-05 04:50:40 EDT
Created attachment 915103 [details]
Comment

(This comment was longer than 65,535 characters and has been moved to an attachment by Red Hat Bugzilla).
Comment 2 Need Real Name 2002-06-05 18:32:18 EDT
Update - I tried to install Redhat with a finalized CD-R, but there was no 
difference: it crashed while installing openjade.
Comment 3 Michael Fulbright 2002-06-06 12:08:29 EDT
Did you happen to test the CDs using the builtin mediacheck?

Try http://people.redhat.com/~msf/mediacheck.html
Comment 4 Need Real Name 2002-06-06 16:46:53 EDT
Yes, I did - both passed.

However, I went back and selected as few packages to install as possible.  After
I tried this, Redhat did install.  Since this was not near what I wanted, I went
back through and selected some more packages (but not nearly as many as I had at
first).  Redhat again successfully installed, but I noticed something
interesting: openjade is the first RPM to install off the second CD.  I think
that anaconda, for some reason, did not ask for the 2nd CD with the package
configuration I had selected.  That would somewhat explain the "SystemError:
(16, 'Device or resource busy')" error: perhaps it was looking for a CD that was
not in the drive.  Once again, this seems to point towards a bug, though odd it
is.  Oh yeah - I originally selected all the packets to install except for
"Dialup Support" and "All Packets."  I believe the install size was about 2.1 GB.
Comment 5 Michael Fulbright 2002-06-12 12:59:10 EDT
Thanks for the additional information, I will assign this issue to an engineer.
Comment 6 Jeremy Katz 2002-06-21 16:47:40 EDT
There was a case where rereading from the CD didn't properly close the file
descriptor on the CD making it impossible to eject.  Fixed in our current
internal codebase.

Note You need to log in before you can comment on or make changes to this bug.