Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 661344 - sane-backends-libs-gphoto2 should not provide the 'libsane.so.1()(64bit)' capability
Summary: sane-backends-libs-gphoto2 should not provide the 'libsane.so.1()(64bit)' cap...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: sane-backends
Version: 13
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-08 16:03 UTC by Andrew J. Schorr
Modified: 2011-04-04 11:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-04-04 11:47:32 UTC
Type: ---


Attachments (Terms of Use)

Description Andrew J. Schorr 2010-12-08 16:03:36 UTC
Description of problem:  There seems to be a packaging error in sane-backends.  The sane-backends-libs-gphoto2-1.0.21-5.fc13.x86_64.rpm claims to provide the libsane.so.1()(64bit) capability, but it does not -- that capability is provided by sane-backends-libs-1.0.21-5.fc13.x86_64.rpm



Version-Release number of selected component (if applicable):
1.0.21-5.fc13

How reproducible: Use "rpm" or "repoquery" to see that this rpm is claiming to provide a capability that it does not actually offer.


Steps to Reproduce:
1. rpm --provides -qp sane-backends-libs-gphoto2-1.0.21-5.fc13.x86_64.rpm
2.
3.
  
Actual results:
libsane.so.1()(64bit)  
sane-backends-libs-gphoto2 = 1.0.21-5.fc13
sane-backends-libs-gphoto2(x86-64) = 1.0.21-5.fc13



Expected results:
sane-backends-libs-gphoto2 = 1.0.21-5.fc13
sane-backends-libs-gphoto2(x86-64) = 1.0.21-5.fc13


Additional info:

Comment 1 Nils Philippsen 2011-04-04 11:47:32 UTC
This is an idiosyncrasy of how the sane driver shared object files are built in combination with that RPM checks the SANE private directories for provides. I've looked into this, but found now easy way to cleanly fix this, but since sane-backends-libs-gphoto2 requires -libs, no real harm is done.


Note You need to log in before you can comment on or make changes to this bug.