Bug 661397 - reboot(RB_AUTOBOOT) fails if kvm instance is running
reboot(RB_AUTOBOOT) fails if kvm instance is running
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.5.z
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
: ZStream
Depends On: 608709
Blocks: Rhel5KvmTier1
  Show dependency treegraph
 
Reported: 2010-12-08 13:18 EST by RHEL Product and Program Management
Modified: 2013-01-10 22:39 EST (History)
15 users (show)

See Also:
Fixed In Version: kvm-83-164.el5_5.29
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-15 05:12:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
serial log for 5.5.z (1.69 KB, text/plain)
2010-12-15 03:22 EST, Golita Yue
no flags Details

  None (edit)
Description RHEL Product and Program Management 2010-12-08 13:18:11 EST
This bug has been copied from bug #608709 and has been proposed
to be backported to 5.5 z-stream (EUS).
Comment 6 Golita Yue 2010-12-14 07:01:39 EST
Hi AVI,

I did the following test for this bug with kvm-83-164.el5_5.29:

1. For AMD host
   Tried 10 times, cannot reproduce it. (btw, I can reproduce this bug with kvm_83-221 easily)

2. For Intel host
   Tried 3 times, still cannot reproduce it.
   But hit the new problem, when I input reboot -fn in host, the following messages display:

(qemu) exception 0 (0)
rax ffff8801f52b0000 rbx 0000000000006fa0 rcx 0000000000001c00 rdx 0000000000000000
rsi ffff8800237d2000 rdi ffff8801f52b2000 rsp 0000000000000000 rbp ffff880028203c88
r8  ffff880024000000 r9  ffffffff8170dec8 r10 00000000ffffffff r11 0000000000000001
r12 0000000000010000 r13 0000000000010000 r14 0000000000000002 r15 ffff880236516420
rip 0000000000000000 rflags 00000000
cs 0000 (00000000/00000000 p 0 dpl 0 db 0 s 0 type 0 l 0 g 0 avl 0)
ds 0000 (00000000/00000000 p 0 dpl 0 db 0 s 0 type 0 l 0 g 0 avl 0)
es 0000 (00000000/00000000 p 0 dpl 0 db 0 s 0 type 0 l 0 g 0 avl 0)
ss 0000 (00000000/00000000 p 0 dpl 0 db 0 s 0 type 0 l 0 g 0 avl 0)
fs 0000 (00000000/00000000 p 0 dpl 0 db 0 s 0 type 0 l 0 g 0 avl 0)
gs 0000 (00000000/00000000 p 0 dpl 0 db 0 s 0 type 0 l 0 g 0 avl 0)
tr 0000 (00000000/00000000 p 0 dpl 0 db 0 s 0 type 0 l 0 g 0 avl 0)
ldt 0000 (00000000/00000000 p 0 dpl 0 db 0 s 0 type 0 l 0 g 0 avl 0)
gdt 0/0
idt 0/0
cr0 8005003b cr2 7fa8c0704000 cr3 0 cr4 b0 cr8 0 efer d01
code: --> 53 ff 00 f0 53 ff 00 f0 53 ff 00 f0 53 ff 00 f0 53 ff 00 f0 53 ff 00 f0 53 ff 00 f0 53 ff 00 f0 a5 fe 00 f0 87 e9 00 f0 53 ff 00 f0 53 ff 00 f0 53 ff

Can you help to check this ?  thanks

steps:
1. start a kvm guest 
2. run some jobs inside the guest. for example dd if=/dev/vda of=a.out bs=1M
count=2048
3. reboot the host by "reboot -fn"

cmd:
/usr/libexec/qemu-kvm -m 8G -smp 4 -uuid `uuidgen` -monitor stdio -boot c -drive file=/dev/vgtest/r6.0-64.raw,if=ide,bus=0,unit=0,boot=on,format=raw,cache=none -net nic,macaddr=00:22:00:73:b5:26,model=virtio,vlan=0 -net tap,vlan=0,script=/etc/qemu-ifup -usb -vnc :1 -soundhw ac97
Comment 7 Avi Kivity 2010-12-14 08:41:11 EST
The second problem (qemu crashes) are expected.  Since the host is rebooting, it isn't a problem anyway.

Please clarify the status wrt:

AMD 5.5.z
Intel 5.5.z
AMD 5.6
Intel 5.6

Do we have a regression on AMD?

So many cases, I got confused.
Comment 8 Golita Yue 2010-12-15 03:20:42 EST
Hi Avi,

The following are my testing result:

      5.5.z(kvm-83-164.el5_5.29) | 5.6(kvm-83-221.el5)
----------------------------------------------------------
AMD   reproduced                 | reproduced
----------------------------------------------------------
Intel passed(tested 10 times)    | passed(tested 10 times)
----------------------------------------------------------

Attached serial log for 5.5.z(kvm-83-164.el5_5.29).
Comment 9 Golita Yue 2010-12-15 03:22:03 EST
Created attachment 468791 [details]
serial log for 5.5.z
Comment 10 Golita Yue 2010-12-15 03:25:50 EST
steps:
1. start a kvm guest 
2. run 'stress' inside the guest
3. reboot the host by "reboot -fn"

cmd:
/usr/libexec/qemu-kvm -m 8G -smp 8 -uuid `uuidgen` -monitor stdio -boot c -drive file=/dev/vgtest/r6.0-64.raw,if=ide,bus=0,unit=0,boot=on,format=raw,cache=none -net nic,macaddr=00:22:00:73:b5:26,model=virtio,vlan=0 -net tap,vlan=0,script=/etc/qemu-ifup -usb -vnc :1 -soundhw ac97

Note You need to log in before you can comment on or make changes to this bug.