Bug 661419 - subscription-manager-gui: no error message when trying to open second instance
Summary: subscription-manager-gui: no error message when trying to open second instance
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.1
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Justin Harris
QA Contact: J.C. Molet
URL:
Whiteboard:
Depends On:
Blocks: Entitlement-Beta
TreeView+ depends on / blocked
 
Reported: 2010-12-08 19:05 UTC by J.C. Molet
Modified: 2013-07-04 21:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-19 13:38:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:0611 normal SHIPPED_LIVE new package: subscription-manager 2011-05-18 17:56:21 UTC

Description J.C. Molet 2010-12-08 19:05:49 UTC
Description of problem:

When you try to open up a second instance of the subscription-manager-gui it doesn't open (this is the correct behavior), but there is no friendly message letting you know that the program is already open in another instance.  Currently it looks like it fails without reason.

Version-Release number of selected component (if applicable):

subscription-manager-gnome-0.93.2-1.git.91.7f89664.fc14.x86_64
subscription-manager-0.93.2-1.git.91.7f89664.fc14.x86_64

How reproducible:
always

Steps to Reproduce:
1. Install subscription-manager and subscription-manager-gui on a machine.
2. Open up one instance of subscription manager gui.
3. Open up a second instance of subscription manager gui.
  
Actual results:

The program doesn't open and no error message is given:

[root@mgmt5 ~]# subscription-manager-gui 
[root@mgmt5 ~]#

Expected results:

The program would let you know that it is already open with a message printed to the console.

Comment 1 Justin Harris 2010-12-13 14:34:48 UTC
Added a model dialog with a message that an instance is already running.

Commit 855593060f93d97f1db111d98173079fe4a4acd3

Comment 2 J.C. Molet 2010-12-13 19:17:40 UTC
version:
subscription-manager-gnome-0.93.3-1.git.19.7e709b6.fc14.x86_64
subscription-manager-0.93.3-1.git.19.7e709b6.fc14.x86_64

Test:
[root@jmolet-vm1 ~]# subscription-manager-gui &
[1] 30507
[root@jmolet-vm1 ~]# subscription-manager-gui
subscription-manager-gui is already running
[root@jmolet-vm1 ~]# 

(this is also followed by a gui pop-up saying the same thing).

Bug looks fixed.

Comment 3 John Sefler 2010-12-13 19:20:03 UTC
moving to VERIFIED on behalf of jmolet

Comment 4 errata-xmlrpc 2011-05-19 13:38:04 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0611.html


Note You need to log in before you can comment on or make changes to this bug.