Bug 66142 - X server kills client application
X server kills client application
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86-Servers (Show other bugs)
7.2
i686 Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-05 08:20 EDT by Lars Rydahl
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-05 08:32:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tar file of program showing the bug. Extract by tar -xvf bugtest.tar (860.00 KB, application/octet-stream)
2002-06-05 08:28 EDT, Lars Rydahl
no flags Details
The executable that demonstrates the bug (236.57 KB, application/octet-stream)
2002-06-05 08:32 EDT, Lars Rydahl
no flags Details

  None (edit)
Description Lars Rydahl 2002-06-05 08:20:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 
1.0.3705)

Description of problem:
Client program is killed by X server after approx 15 seonds with msg:
"X connection to :0.0 broken (explicit kill or server shutdown)"

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run my little test program "bugtest" from the unix promt.
2.Wait for 15 seconds.
3.See bugtest being killed by the X server.
	

Actual Results:  Application is killed and you see the message "X connection 
to :0.0 broken (explicit kill or server shutdown)".

Expected Results:  I like my application te be left running.

Additional info:

I will attach my little test application together with it's source. If you run 
it as compiled now, the bug will show itself as described above. However, if 
you uncomment the code in bugtest.c enclosed by "Lars bugfix block" and then 
recompile, "bugtest" will be left alive. Of course, this workaround is only 
possible in code that you are free to manipulate, but it should aid you to find 
the bug. The real problem is with an application that I purchased compiled.
Comment 1 Lars Rydahl 2002-06-05 08:28:51 EDT
Created attachment 59744 [details]
tar file of program showing the bug. Extract by tar -xvf bugtest.tar
Comment 2 Lars Rydahl 2002-06-05 08:32:19 EDT
Created attachment 59745 [details]
The executable that demonstrates the bug
Comment 3 Mike A. Harris 2002-06-05 18:33:24 EDT
The X server does not _ever_ kill any client application.  You are totally
misinterpreting the error message.

What the message is saying, is that your program lost it's connection to
the X server.  The error message hypothesizes potential reasons why, and
one of them is that the program may have been killed - not by the X server,
which is totally impossible, but for some other reason including the
application crashing.

I consider this problem entirely a bug in your software, and not an
X server bug.  If you need assistance determining the source of the
problem, and possibly finding a solution, I suggest subscribing to
the xpert@xfree86.org mailing list, posting the problem you're having,
and getting feedback from the hundreds of developers there.

If after doing so, it turns out there is in fact a bug in the X server,
feel free to reopen this bug report, and include all of the details from
your research on the xpert list.  Also report said findings to the
official XFree86 bug reporting address of xfree86@xfree86.org, which
should the problem truely be an X problem, will accelerate the likelyhood
of the problem being looked at and addressed.



Note You need to log in before you can comment on or make changes to this bug.