Bug 661438 - SELinux is preventing /usr/bin/python "lock" access on /etc/selinux/targeted/modules/semanage.trans.LOCK.
Summary: SELinux is preventing /usr/bin/python "lock" access on /etc/selinux/targ...
Keywords:
Status: CLOSED DUPLICATE of bug 661409
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 13
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:d1057a39314...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-08 19:25 UTC by maurizio
Modified: 2010-12-08 20:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-08 20:36:55 UTC
Type: ---


Attachments (Terms of Use)

Description maurizio 2010-12-08 19:25:24 UTC
Summary:

SELinux is preventing /usr/bin/python "lock" access on
/etc/selinux/targeted/modules/semanage.trans.LOCK.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by semanage. It is not expected that this access
is required by semanage and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                mauricio:user_r:user_t:s0-s0:c0.c1023
Target Context                system_u:object_r:semanage_trans_lock_t:s0
Target Objects                /etc/selinux/targeted/modules/semanage.trans.LOCK
                              [ file ]
Source                        semanage
Source Path                   /usr/bin/python
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           python-2.6.4-25.fc13
Target RPM Packages           selinux-policy-targeted-3.7.19-69.fc13
Policy RPM                    selinux-policy-3.7.19-69.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.34.7-61.fc13.i686
                              #1 SMP Tue Oct 19 04:42:47 UTC 2010 i686 i686
Alert Count                   2
First Seen                    Wed 08 Dec 2010 09:44:53 AM MST
Last Seen                     Wed 08 Dec 2010 09:45:07 AM MST
Local ID                      e8ac9c96-ea63-44f6-9443-638234c6b629
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1291826707.215:80): avc:  denied  { lock } for  pid=2408 comm="semanage" path="/etc/selinux/targeted/modules/semanage.trans.LOCK" dev=dm-0 ino=60766 scontext=mauricio:user_r:user_t:s0-s0:c0.c1023 tcontext=system_u:object_r:semanage_trans_lock_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1291826707.215:80): arch=40000003 syscall=143 success=yes exit=0 a0=3 a1=8 a2=5d6424 a3=b321240 items=0 ppid=2407 pid=2408 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="semanage" exe="/usr/bin/python" subj=mauricio:user_r:user_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,semanage,user_t,semanage_trans_lock_t,file,lock
audit2allow suggests:

#============= user_t ==============
allow user_t semanage_trans_lock_t:file lock;

Comment 1 Daniel Walsh 2010-12-08 20:36:55 UTC

*** This bug has been marked as a duplicate of bug 661409 ***


Note You need to log in before you can comment on or make changes to this bug.