This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 66160 - kdepim rpm "Requires" clause misses kdelibs
kdepim rpm "Requires" clause misses kdelibs
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.3
i386 Linux
low Severity low
: ---
: ---
Assigned To: Adrian Likins
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-05 12:26 EDT by Ingo T. Storm
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-05 10:37:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ingo T. Storm 2002-06-05 12:26:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020509

Description of problem:
I installed kdepim fine through up2date. korganizer does not start, though: 

# korganizer  
korganizer: error while loading shared libraries: libkdeprint.so.0: cannot open
shared object file: No such file or directory

This lib is in kdelibs, which should have been required.

Version-Release number of selected component (if applicable):
kdelibs-2.2.2-2
kdepim-2.2.2-3

How reproducible:
Always

Steps to Reproduce:
1. up2date -i kdepim
2. korganizer &
3. see error message above
4. up2date -i kdelibs
5. korganizer &
6. everyhing's fine :-)
	

Actual Results:  korganizer does not start

Expected Results:  korganizer should have started

Additional info:

this was a kickstart install without kde, but WindowMaker as desktop
Comment 1 Bernhard Rosenkraenzer 2002-06-19 07:23:56 EDT
up2date should really resolve implicit dependencies
Comment 2 Adrian Likins 2002-08-08 23:33:14 EDT
what exactly do you mean by "implicit dependencies"? 

up2date resolves lib deps, file deps, and explicit deps ("Require: foo").

But in this case, I'm not sure what the issue is.

The bug report is against 7.3, but the versions
of "kdepim" and "kdelibs" mentioned are not in 7.3.
Comment 3 Ingo T. Storm 2003-11-05 10:37:13 EST
hmm. so sorry, completely lost track of this one... CLOSED it, is 
probably NOTABUG.

Ingo


Note You need to log in before you can comment on or make changes to this bug.