Bug 66161 - ntpd is started before named in the rc scripts
Summary: ntpd is started before named in the rc scripts
Status: CLOSED DUPLICATE of bug 46464
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ntp (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-05 16:42 UTC by John L. Chmielewski
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-07 19:49:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John L. Chmielewski 2002-06-05 16:42:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc3) Gecko/20020523

Description of problem:
hostnames are permitted in the ntp.conf and step-tickers files, but unless IP
addresses are used in /etc/ntp/step-tickers, ntpd will fail when the computer is
started, because named is not yet running.  If ntpd is restarted after the
computer is up, it is successful.  The ntpd script should start before the named
script.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.create /etc/ntp/step-tickers with one line: tick.usno.navy.mil 
2.do a "service ntpd restart" (see that it successfully starts)
3.reboot computer, and watch as ntpd tries to start, it will indicate  that it
failed.
	

Actual Results:  ntpd will fail when the computer boots, but if you restart ntpd
using the service command it will start OK.

Expected Results:  ntpd should have started

Additional info:

If step-tickers has an IP address instead of a host name, it will start properly
when the computer starts.  The named service should start before the ntpd
service to correct this problem.

Comment 1 Joe Bayes 2002-06-07 19:49:20 UTC
See also bug 46464.

Also, I think in your first paragraph, you mean that named should start before
ntpd, correct?


Comment 2 Harald Hoyer 2002-06-11 14:06:41 UTC

*** This bug has been marked as a duplicate of 46464 ***


Note You need to log in before you can comment on or make changes to this bug.