Bug 661623 - don't package INSTALL
Summary: don't package INSTALL
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: autoconf
Version: rawhide
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Pavel Raiskup
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-09 08:53 UTC by Rahul Sundaram
Modified: 2013-01-23 10:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-23 10:02:54 UTC
Type: ---


Attachments (Terms of Use)

Description Rahul Sundaram 2010-12-09 08:53:37 UTC
Description of problem:

rpm -qf /usr/share/autoconf/INSTALL
autoconf-2.66-2.fc14.noarch

http://fedoraproject.org/wiki/PackagingGuidelines#Documentation

Comment 1 Pavel Raiskup 2012-09-27 05:43:33 UTC
Thanks for your catch!

I fixed it in f1[678] & rawhide.  Fix will be available in (possible) future
updates.

Pavel

Comment 2 Fedora Update System 2013-01-14 12:27:30 UTC
autoconf-2.69-7.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/autoconf-2.69-7.fc18

Comment 3 Fedora Update System 2013-01-14 14:06:51 UTC
autoconf-2.68-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/autoconf-2.68-6.fc17

Comment 4 Eric Blake 2013-01-15 03:23:30 UTC
Are you sure this is the right course of action?  Autoconf is the upstream source of INSTALL; so unlike every other package out there, autoconf's version is actually the canonical one, and installing the INSTALL file lets other autoconf'd packages copy this canonical version.

Comment 5 Pavel Raiskup 2013-01-15 06:46:26 UTC
(In reply to comment #4)
> Are you sure this is the right course of action?  Autoconf is the
> upstream source of INSTALL; so unlike every other package out there,
> autoconf's version is actually the canonical one, and installing the
> INSTALL file lets other autoconf'd packages copy this canonical version.

Eric, you are right.  I missed the generality of this file, sorry.

Reopening, I'll revert this change.

Pavel

Comment 6 Fedora Update System 2013-01-16 19:21:47 UTC
Package autoconf-2.68-7.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing autoconf-2.68-7.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-0821/autoconf-2.68-7.fc17
then log in and leave karma (feedback).

Comment 7 Pavel Raiskup 2013-01-23 10:02:54 UTC
Reverted.  Closing as NOTABUG.

Pavel


Note You need to log in before you can comment on or make changes to this bug.