Bug 661632 - Providing native systemd file for upcoming F15 Feature Systemd
Providing native systemd file for upcoming F15 Feature Systemd
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pads (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Steve Grubb
Fedora Extras Quality Assurance
:
Depends On:
Blocks: SysVtoSystemd
  Show dependency treegraph
 
Reported: 2010-12-09 04:29 EST by Michał Piotrowski
Modified: 2012-02-20 10:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-20 10:02:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
pads.service (241 bytes, text/plain)
2010-12-09 04:32 EST, Michał Piotrowski
no flags Details
Native systemd unit for pads (200 bytes, text/plain)
2012-02-19 16:23 EST, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Michał Piotrowski 2010-12-09 04:29:03 EST
The attached file is a native systemd file for upcoming F15 Feature [1]

Please read [2] on how to packaging and installing systemd Service files.

To learn more about Systemd daemon see [3].

To view old SysV with the new Systemd site by site see for your component see [4]

If you have any question dont hesitate to ask them on this bug report.

1.http://fedoraproject.org/wiki/Features/systemd

2.https://fedoraproject.org/wiki/Systemd_Packaging_Draft

3.http://0pointer.de/public/systemd-man/daemon.html

4.https://fedoraproject.org/wiki/User:Johannbg/QA/Systemd/compatability
Comment 1 Michał Piotrowski 2010-12-09 04:32:42 EST
Created attachment 467712 [details]
pads.service

To run this service I had to remove quotation marks from /etc/sysconfig/pads to get

# Config file location
CONFIG_FILE=/etc/pads.conf

# Add extra options here
EXTRA_OPTIONS=

because of systemd bug/issue/whatever that will be resolved later.
Comment 2 Jon Ciesla 2012-02-13 14:36:31 EST
Steve, any objection to my making this change?
Comment 3 Steve Grubb 2012-02-19 15:41:33 EST
Feel free to make the changes.
Comment 4 Jóhann B. Guðmundsson 2012-02-19 16:23:13 EST
Created attachment 564224 [details]
Native systemd unit for pads

updating and fixing that submitted unit file...

/etc/sysconfig/foo Environment files are in a sense obsolete and Fedora/Red Hat
distribution specific thus wont fly with upstream when you submit the units
there.

The future and distribution agnostic way to customize units for daemons that do
not support parsing a config file is this.

http://fedoraproject.org/wiki/Systemd#How_do_I_customize_a_unit_file.2F_add_a_custom_unit_file.3F
Comment 5 Jon Ciesla 2012-02-20 10:02:14 EST
Done, thanks all!

Note You need to log in before you can comment on or make changes to this bug.