Bug 661666 - The upcoming audit patch causes inability to run sshd as non root
The upcoming audit patch causes inability to run sshd as non root
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
rawhide
All Linux
high Severity urgent
: ---
: ---
Assigned To: Jan F. Chadima
Fedora Extras Quality Assurance
: Regression
: 660963 661394 (view as bug list)
Depends On:
Blocks: 661394 661669
  Show dependency treegraph
 
Reported: 2010-12-09 05:46 EST by Jan F. Chadima
Modified: 2011-01-26 11:15 EST (History)
5 users (show)

See Also:
Fixed In Version: openssh-server-5.6p1-21.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 661669 (view as bug list)
Environment:
Last Closed: 2011-01-26 11:15:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan F. Chadima 2010-12-09 05:46:34 EST
Description of problem:
the audit code finist the session with EPERM

Version-Release number of selected component (if applicable):


How reproducible:
allways

Steps to Reproduce:
1.
run /usr/sbin/sshd as non root user
2.
run ssh localhost
3.
  
Actual results:
connection is broken


Expected results:
the ssh works as expected

Additional info:
Comment 1 Jan F. Chadima 2010-12-09 05:47:52 EST
The solution is change the openssh's audit code according to pam's one.
Comment 2 Jan F. Chadima 2010-12-09 06:25:24 EST
*** Bug 661394 has been marked as a duplicate of this bug. ***
Comment 3 Kamil Dudka 2010-12-14 04:54:33 EST
FTBFS libssh2-1.2.7-1.fc15 appears fixed
Comment 4 Kamil Dudka 2010-12-14 04:55:33 EST
*** Bug 660963 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.