Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 661666 - The upcoming audit patch causes inability to run sshd as non root
Summary: The upcoming audit patch causes inability to run sshd as non root
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: openssh
Version: rawhide
Hardware: All
OS: Linux
high
urgent
Target Milestone: ---
Assignee: Jan F. Chadima
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 660963 661394 (view as bug list)
Depends On:
Blocks: 661394 661669
TreeView+ depends on / blocked
 
Reported: 2010-12-09 10:46 UTC by Jan F. Chadima
Modified: 2011-01-26 16:15 UTC (History)
5 users (show)

Fixed In Version: openssh-server-5.6p1-21.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 661669 (view as bug list)
Environment:
Last Closed: 2011-01-26 16:15:20 UTC
Type: ---


Attachments (Terms of Use)

Description Jan F. Chadima 2010-12-09 10:46:34 UTC
Description of problem:
the audit code finist the session with EPERM

Version-Release number of selected component (if applicable):


How reproducible:
allways

Steps to Reproduce:
1.
run /usr/sbin/sshd as non root user
2.
run ssh localhost
3.
  
Actual results:
connection is broken


Expected results:
the ssh works as expected

Additional info:

Comment 1 Jan F. Chadima 2010-12-09 10:47:52 UTC
The solution is change the openssh's audit code according to pam's one.

Comment 2 Jan F. Chadima 2010-12-09 11:25:24 UTC
*** Bug 661394 has been marked as a duplicate of this bug. ***

Comment 3 Kamil Dudka 2010-12-14 09:54:33 UTC
FTBFS libssh2-1.2.7-1.fc15 appears fixed

Comment 4 Kamil Dudka 2010-12-14 09:55:33 UTC
*** Bug 660963 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.