Bug 661736 - Consider renaming qmf subpackage to qpid-qmf
Consider renaming qmf subpackage to qpid-qmf
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qpid-cpp (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Nuno Santos
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-09 09:46 EST by Jaroslav Reznik
Modified: 2013-09-12 18:11 EDT (History)
6 users (show)

See Also:
Fixed In Version: qpid-cpp-0.10-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-11 00:24:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Reznik 2010-12-09 09:46:24 EST
Description of problem: we are currently working on packaging of QMF (Qt Messaging Framework) to Fedora and we'd like to avoid confusion with QMF (Qpid one) as much as possible. For now, we plan to call it qt-qmf or even qt-messaging (even it breaks naming compatibility with other distributions but it's not a problem - as many packages differs). If you could consider renaming qmf subpackage to qpid-qmf it would be better for future life side by side (for example other subpackages, bindings etc.) in Fedora.
 
Actual results:
qmf package

Expected results:
qpid-qmf package
Comment 1 Rex Dieter 2011-01-14 10:36:22 EST
ping?  A month has passed.  Any comment please.
Comment 2 Nuno Santos 2011-01-25 13:38:56 EST
I'm not opposed to the rename, but I'll bring up the issue upstream, since there are currently discussions going on about where qmf fits within the whole qpid project. Will update when I get any development.
Comment 3 Nuno Santos 2011-02-22 12:41:24 EST
Done in version qpid-cpp-0.8-6.fc16 , see http://koji.fedoraproject.org/koji/buildinfo?buildID=230153

Renamed subpackages:
qmf -> qpid-qmf
qmf-devel -> qpid-qmf-devel
python-qmf -> python-qpid-qmf
ruby-qmf -> ruby-qpid-qmf
Comment 4 Fedora Update System 2011-02-22 16:16:45 EST
qpid-cpp-0.8-6.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/qpid-cpp-0.8-6.fc15
Comment 5 Fedora Update System 2011-06-08 18:29:32 EDT
qpid-cpp-0.10-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/qpid-cpp-0.10-2.fc15
Comment 6 Fedora Update System 2011-06-11 00:24:39 EDT
qpid-cpp-0.10-2.fc15, python-qpid-0.10-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.